On the new FB homepage, switching content from Top News to Most Recent gives inconsistent accessibility results, but visual display is OK

VERIFIED WORKSFORME

Status

()

Core
Disability Access APIs
--
major
VERIFIED WORKSFORME
8 years ago
7 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({regression})

1.9.2 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
STR:
1. Go to http://www.facebook.com and log in.
2. On your home page, switch the "News" feed to "Most Recent".
3. Compare if accessibility tree and visual display of new items match.
4. Switch back to "Top news".
5. Switch back to "Most Recent".
6. Verify:
a) Visual display is the same as the last time you switched to Most Recent. You may get a new item at the top if your friends are very active, but the items below should still be roughly the same.
b) That this also gets reflected in the accessibility tree.

Results I'm seeing:
1. In 3.5.7, I always get a consistent view of the Most Recent items.
2. In 3.6 release, and 3.7a2pre Minefield builds, however, I get inconsistent results with NVDA. Also refreshing the buffer doesn't give me the eexpected results. Often, items are randomly missing, and on occasion I even get a display of "no items to display" in the virtual buffer.

A friend verified that he never sees the "no items to display", and that he always gets the same visual consistent result in both Firefox 3.6 and current version of Chrome.

Conclusion: Since Facebook switched to their new design end of week of February 1, this problem surfaced. It was never a problem with the older design when these "Most Recent" were still called "Live Feed".

I verified this is a problem in 3.6 release, but not 3.5.7.

Comment 1

8 years ago
(In reply to comment #0)

> Results I'm seeing:
> Also refreshing the buffer doesn't give me the eexpected
> results. Often, items are randomly missing, and on occasion I even get a
> display of "no items to display" in the virtual buffer.

If refreshing doesn't help then it's not related with events, therefore I tried to investigate the a11y tree by DOMi and can't reproduce the bug.

Comment 2

8 years ago
Can't reproduce by NVDA (0.6p3.2), when I tab, switch between "Top news" and "Most Recent" then I can tab into items.
(Reporter)

Comment 3

8 years ago
I'm using NVDA 2009.1 which has a significantly newer VirtualBuffer backend and other fixes.

Also, when you tab to the "Most recent" items, are these the same each time? E. G. do you always get the same items posted by friends recently? Here's where I see a difference: I see items, I can tab into them as well, but they're not always the same. Some items sometimes randomly disappear from one switch to the next, only to reappear on the next switch.

Comment 4

7 years ago
Marco, do we have a problem here today?
(Reporter)

Comment 5

7 years ago
No, this is WFM in Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.