Allow removing the saved column list of a saved search

NEW
Unassigned

Status

()

Bugzilla
Query/Bug List
P3
enhancement
8 years ago
4 years ago

People

(Reporter: Onno Garms, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: 3.4.5

It should be possible to remove the column selection for a saved search.
I.e., if there is the checkbox
"Save this column list only for search 'MySearch'"
there should be a button saying
"Reset to global columns"
in addition to the button "Reset to Bugzilla default".

Clicking on "Reset to global columns" should remove the individual columns for the saved search. I.e. if global columns are changed later, the change should automatically apply to the saved search.

Currently there seems to be no way to forget search specific columns once they are set up. (Appart from forgetting and redoing the search of course.) If there is such a possibility, it should be documented.

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → 3.4.5

Comment 1

8 years ago
I'm sort of vaguely remembering that dkl knows something about this area of the code?
Summary: Reset columns to global columns → Allow removing the saved column list of a saved search
(In reply to comment #1)
> I'm sort of vaguely remembering that dkl knows something about this area of the
> code?

I think you may be referring to bug 443479.

Dave

Comment 3

8 years ago
  Right, this bug sounds identical to that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443479
(Reporter)

Comment 4

8 years ago
I haven't tried the patch offered in bug 443479, but from reading the comments there this doesn't look like a duplicate to me.

Bug 443479 basically says: "Reset to bugzilla default" does not reset search specific columns to anything. That behaviour was a ("minor") bug.

This Bug 544839 says: In addition to "Reset to bugzilla default" I want to be able to "Reset to global columns". That is an enhancement request.

Tell me if I should be wrong. Otherwise I'll remove the resultion soon (in case I have the rights to do so; didn't try).

Comment 5

8 years ago
 Oh, yes, I see. Perhaps that's what the Reset button should be doing instead, is simply removing the columnlist parameter of the search.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Priority: -- → P3
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Perhaps that's what the Reset button should be doing instead,
> is simply removing the columnlist parameter of the search.

Yes, changing the functionality of the existing button instead of adding a second button would be an acceptable alternative for me. 

Currently we have:
1. "Reset" without "only search"
   => set global columns to bugzilla default
2. "Reset" with "only search"
   => set search-specific columns to bugzilla default

This should be changed to
1. "Reset" without "only search"
   => set global columns to bugzilla default
      *and*
      remove search-specific columns
2. "Reset" with "only search"
   => remove search-specific columns

Please note:
- Removing search specific columns is *not* equivalent to setting search-specific columns to *current* global columns.
- Please also note that the button "Reset to bugzilla default" should be renamed to "Reset".
- By fixing in above way one can no longer set search specific columns to bugzilla default. I don't need that anyway, but I don't know if others need that. That's why I initially suggested an additional button.
You need to log in before you can comment on or make changes to this bug.