form-input-type=file should accept "drag and drop"

RESOLVED DUPLICATE of bug 50660

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED DUPLICATE of bug 50660
8 years ago
8 years ago

People

(Reporter: Emil Obermayr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7

Very often you have the file you want to upload somewhere visible in your OS' file browser or even on the desktop. It would improve the "look and feel" a lot if drag and drop would be possible. It is possible with normal clipboard text to type=text, so it shouldnt be a big problem on the UI side. 

I guess the main issue is the error handling when the dropped information is not a valid filename. I'd say this could be handled with a popup similar to the other warnings when sending form-data.

Reproducible: Always

Steps to Reproduce:
1. have a html-form with type=file
2. drag'n'drop a file from desktop or OS-specific file browser to the file-input field

Actual Results:  
a new tab opens showing the file, like it would have been dropped without hitting the form-input

Expected Results:  
entering the filename to the input field as upload file

workaround: open the file-dialog first and drop there

(very cumbersome, but shows up that it can not be a big problem basically)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 50660
You need to log in before you can comment on or make changes to this bug.