Some messages are not rendered properly, fancy HTML code displayed instead

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: andrea.ippo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-09-10)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

It happens that some messages are not display correctly by TB.
The pane showing the message content only shows some of the mail source code.
I think further investigation is needed, sadly I'm not able to reproduce this, but is seems that once the message has been downloaded, it's always displayed in that fancy way.
As you can see from the screenshots, Gmail webmail displays it correctly, so it must have get corrupted when downloaded by Thunderbird:
http://www.imagesticky.com/images/m6tpx848n5k06vk1cq3.png
http://www.imagesticky.com/images/fe7dxbyos1t79y8vmujs.png

Examining the source code, I think something's wrong: part of the email source stays BEFORE the header information (see attachment). Could this be the cause of the rendering problems?



Reproducible: Couldn't Reproduce
(Reporter)

Comment 1

9 years ago
Created attachment 425814 [details]
source code of email Thunderbird is unable to render
(Reporter)

Comment 2

9 years ago
I just tried 3.1 alpha1, same problem (because the message source is corrupted, so 3.1 can do nothing to fix it).
Rebuilding the IMAP folder index worked, now the message is displayed correctly, so I think it's definitely Thunderbird that messes up the source while downloading the message source. Perhaps it uses chunks and sometimes doesn't re-order them correctly?
It's difficult to tell without knowing the details of Thunderbird's interaction with the server. I'm not sure if a protocol log would help here (https://wiki.mozilla.org/MailNews:Logging), but it's worth a shot -- obviously, the tricky bit would be capturing a log at the right time, i.e., when Thunderbird is downloading a message that later turns out to have corrupt header information.
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
(Reporter)

Comment 4

9 years ago
If you think it can help, I could try.
I don't know this mechanism and how it works, do I have to install something/have something running in background?

Comment 5

9 years ago
It's probably not helpful unless you can recreate the problem of downloading a message and having it not display correctly.
(Reporter)

Comment 6

9 years ago
No, I can't reproduce it.
It happened to me 3-4 times until now (started having this problem with version 3.0), and always with mails that have nothing to do with each other (same sender or subject or ...). It seems unpredictable to me :(

Comment 7

9 years ago
This could happen if your mbox file is corrupted, try to rebuild index, this is may root of your problem.
(In reply to comment #7)
> This could happen if your mbox file is corrupted, try to rebuild index, this
> is may root of your problem.

This was done, and solved the symptoms of the problem; the root cause, though, is difficult to find (as bienvenu and I noted). Without reliable repro, there's not much anyone can do here, so we'll have to wait for a bit of luck.

(In reply to comment #4)
> If you think it can help, I could try.
> I don't know this mechanism and how it works, do I have to install
> something/have something running in background?

Just in case you are able to start reproducing this, the instructions are at the linked page -- nothing needs to be installed, but you'll have to start Thunderbird differently. Note that the log is likely to be rather large (i.e. several megabytes at least); the smaller a time window around the download of a corrupted message the better.

Comment 9

9 years ago
Andrea, you might to prepare by turning on logging by default (or at least test to see that you can set it up correctly).  

right click on Computer (in desktop or start menu)
properties
advanced 
environment settings
system variables
new
 set variables per https://wiki.mozilla.org/MailNews:Logging#Environment_Variables_to_set
OK, etc.

now logging will happen for every thunderbird startup. not likely to noticeably impact performance - I've even had it enabled on laptops.
(Reporter)

Comment 10

9 years ago
Ok, I've set it up with NSPR_LOG_MODULES set to "imap:5"
Are there other modules/logging levels I should set?

Comment 11

8 years ago
(In reply to comment #10)
> Ok, I've set it up with NSPR_LOG_MODULES set to "imap:5"
> Are there other modules/logging levels I should set?

no, just imap. please base your results on using version 3.1, preferably 3.1.2 or higher.
Whiteboard: closeme 2010-09-10
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → INCOMPLETE
(Reporter)

Comment 13

8 years ago
This issue never happened to me again, so maybe the index file got corrupted for other reasons.
You need to log in before you can comment on or make changes to this bug.