Omnia 2: Cannot delete profiles

RESOLVED WONTFIX

Status

--
critical
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Fennec 1.1
All
Windows Mobile 6 Professional

Details

(Whiteboard: mothballed)

(Reporter)

Description

9 years ago
Build Id:
Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2.2pre) Gecko/20100208 Namoroka/3.6.2pre Fennec/1.0a4pre

Steps to Reproduce:
1. Boot the device
2. Open the file explorer
3. Go to "Application Data/Mozilla/Fennec/Profiles"
4. Try to delete the "xxxxxxx.default" profile 


Actual Results:
I receive the following two pop-ups - 
1. "problem deleting file 'parent'.
2. "Error delete file: Cannot remove folder 'xxxxxx': Access is denied. Be certain that the folder is not write-protected and is not currently in use."

Expected Results:
I should be able to delete the file. This might have something to do with fast-start, but I'm not start.
OS: Windows Mobile 6 Standard → Windows Mobile 6 Professional
ok, removing the \windows\startup\fennecfaststart.lnk file and rebooting allowed me to delete the profile.
I don't know that we necessarily want to fix this per se, but perhaps we can provide a utility to shut down the fast start daemon for advanced users
(Reporter)

Comment 3

9 years ago
I would think we would want to fix this as its pretty difficult, and not very intuitive, for the user to change their profile currently.

Comment 4

9 years ago
(In reply to comment #3)
> I would think we would want to fix this as its pretty difficult, and not very
> intuitive, for the user to change their profile currently.

I don't know where I comment in right place; I use Maemo 5, not Windows. I have related issue: to delete a profile, I start X Terminal, type
fennec -p
select profile
click
Delete Profile
the prompt (Something like "Are you sure?") tries to draw itself, but fails
I click random arrows
hit Enter
dialog closes
profile is deleted
as I wanted.
But: 1. the dialog wasn't able to draw itself; 2. the profile manager seems to be unchanged from desktop, it has small text, small buttons, etc.
It's a minor issue, but it's somewhat counter intuitive.
This year we mothballed windows mobile development.  See:

  http://blog.pavlov.net/2010/03/22/stopping-development-for-windows-mobile/

Marking bugs in the windows mobile / windows ce bucket as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: mothballed
Component: Windows Mobile → General
QA Contact: mobile-windows → general
Hardware: ARM → All
You need to log in before you can comment on or make changes to this bug.