Msg sent from Seamonkey are an hour off if you're on day light saving time

VERIFIED FIXED in M7

Status

MailNews Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: 1999042216 Win32 May 22 build installed on Win32 NT4.0
       1999042108 Linux may 21 build installed on Linux Redhat 5.2

Problem: If your machine is configured to observe day light saving time, message
sent from Seamonkey are an hour a head. This occurs on messages sent from
Seamonkey and received on Seamonkey OR on messages sent from Seamonkey to Nova
4.51.

Work around: On Windows, go into the Date&Time control panel and disable
"Automatically adjust clock for daylight saving changes" and adjust the time
accordingly.  On Linux, the system is set by default to observe day light saving
time.  (I haven't figure out how to change it.)

Steps to reproduce problem on windows
1) Log in as administrator
2) Open the Date&Time control and to make sure the option "Automatically adjust
clock for daylight saving changes" is checked.  If not check the box and click
on the apply button.
3) Verify that the time is set properly
4) Log out as Administrator

5) Log in as yourself
6) Launch Seamonkey
7) Open Messenger
8) Start a new mail message
9) Address the message to yourself, add a title, and a short subject
   (Suggest addressing message to the email account you are using and to an
account running Communicator)
10) Send the message
11) Retrieve the message
    Notice the message is dated an hour ahead.

Updated

19 years ago
Summary: Msg sent from Seamonkey are an hour off if you're on day light saving time → Msg sent from Seamonkey are an hour off if you're on day light saving time
Target Milestone: M6

Comment 1

19 years ago
M6
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
i don't believe this is an m6 bug (feel free to disagree =)) pushing off to
m8...

Comment 3

19 years ago
This does need to be fixed before we have a wider audience for using our mail
product which I don't think is M6.
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M8
(Assignee)

Comment 4

19 years ago
really pushing off to m8 this time instead of saying i am and not changing it =)
(Assignee)

Comment 5

19 years ago
Rich, just checked in a fix for a GMT problem. Rich, do you think the problem in
this bug report is the same thing? Can I mark this as fixed =)?

What was the offset problem you were fixing?

Adding rhp to the cc list in the hopes that this bug just got fixed by him and I
don't have to do anything...

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
This is fixed. An old XP call got replaced incorrectly, so after fixing the
calculation of GMT offset, it works fine now. The fix is in
\mozilla\mailnews\compose\srcnsMsgCompUtils.cpp

- rhp

Updated

19 years ago
QA Contact: lchiang → pmock
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Verified in the June 16 Seamonkey builds.  I tested the following builds:
  Win32 June 16 Seamonkey build (1999061608)
  PPC June 16 Seamonkey build (1999061608)
  Linux June 16 Seamonkey build (1999061608)

Messages sent from seamonkey and viewed in Communicator 4.61 are received with
the correct Date and Time. I was not able to reproduce the problem.

Note: Message viewed on Linux and Win32 display the correct time and date.  On
PPC, there is an outstanding parity bug 5934 that prevent the date and time from
being displayed correctly.

Comment 8

19 years ago
Moving all Mail/News Networking bugs to Mail/News Networking-Mail

This may re-open previously Verified bugs due to a Bugzilla bug...if so, I will
fix those bugs.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.