<iframe> content loads in <frame> after reload

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
18 years ago
24 days ago

People

(Reporter: mk, Assigned: pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000927
BuildID:    2000092720

There's a frameset file with another frameset file within. The second frameset
contains a frame with an <iframe>. After reloading the whole thing the iframe
content is displayed in the sourrounding frame instead of the iframe. 		

Reproducible: Always

Steps to Reproduce: Load the page. Hit reload. Once the page was loaded with the
wrong frames, loading the original frameset with the link on the left doesn't help.		

Actual Results: After reloading there's the white left frame, the blue upper
frame, but in the lower frame is only the red iframe document.			

Expected Results: There should be a white left frame, a blue upper frame, and a
green lower frame with a red iframe within.							

Originally I came across this behavior when I tried to load the iframe content
with JavaScript, but the defect is also there without JavaScript and hardcoded
src. With more complicated framesets, the iframe content is even displayed in
other frames than the original parent frame.

Comment 1

18 years ago
With the Oct 02 build, I'm not able to reproduce this problem. Reloading the
page renders all frames (white, blue, green)including the red iframe. Marking
works for me. Please download the latest nightly build on mozilla.org and try
test case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
Works For Me:
OS: Windows 98
Platform: PC
Mozilla Build #: 2000100508
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
Having problems with this issue.  Possibly reopen?

Steps to reproduce-->
STEP 1: Create an html file containing:
<frameset rows="*,*"><frame src="iframe.html"><frame src="iframe.html"></frameset>



STEP 2: Create another html file called 'iframe.html' containing:
<HTML> <HEAD> <SCRIPT> var n = -1;
function createBlankIframe () {
  n++;
  var iframe = document.createElement('IFRAME');
  iframe.id = iframe.name = 'iframe' + n;
  iframe.src = 'about:blank';
  document.body.appendChild(iframe);
}
function writeToIframe() {
  var ifrWin = window.frames['iframe' + n];
  ifrWin.document.open();
  ifrWin.document.write('<H1>Kibology<\/H1>');
  ifrWin.document.close();
}
</script> </HEAD> <BODY> <BUTTON ONCLICK="createBlankIframe();
writeToIframe();"> create blank iframe and write to it
</BUTTON> <BUTTON ONCLICK="createBlankIframe();"> create blank iframe
</BUTTON> <BUTTON ONCLICK="writeToIframe()"> write to iframe
</BUTTON> <BUTTON ONCLICK="createBlankIframe(); setTimeout('writeToIframe();',
1)"> create blank iframe and write delayed to it
</BUTTON> <BR> </BODY> </HTML>



STEP 3:  Load up frames page.  Click on fourth button in either frame.  Click
Reload button.

Notice that the frame that you had clicked in is now replaced with about:blank.




Workaround:  Reload the page by hitting enter in the URL bar.


I tested this on Netscape 6.01, 6.1 Pre-release, and Mozilla 0.9.2 with similar
results.

Updated

27 days ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.