If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Umlauts cause problems on copy from local folders to IMAP

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: tessarakt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.2) Gecko/20100115 Firefox/3.1b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b2pre Thunderbird/3.0.1

I am currently copying mails to IMAP, as part of a migration.

I now copied the folder "Contacts" and its subfolders. Some subfolders have umlauts (ü, ä, ö ...) in their name. (e.g. "Äxyz")

I can open these folders just fine in local folders, and see the messages. They also appear normally in the file system (with .msf and .sbd).

But when I try to copy "Contacts", "Äxyz" is empty on the IMAP side, and copying stops after that (without a message or any trace in the activity manager).

After I delete Äxyz.msf and Äxyz.sbd and rename Äxyz to Aexyz, copying works (but stops at the next problematic folder ...).

Reproducible: Always
Can you get IMAP log for your folder copy? (attach log file to this bug. never paste, please)  
> https://wiki.mozilla.org/MailNews:Logging
> http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25328
> NSPR_LOG_MODULES=timestamp,imap:5

> After I delete Äxyz.msf and Äxyz.sbd

Tb looks to use folder name & file name in windows-1252 or something else. 
As non-ascii folder name character is passed in modified UTF-7 if IMAP, problem like this bug usually won't occur, if "create folder of Äxyz" is requested via UI.
Does "new folder, Äxyz" at the IMAP account work? If yes, what is displayed at  Location: of folder properties of created IMAP folder of Äxyz?
What is charset in locale related setting of your Linux? UTF-8? Or other?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Can you get IMAP log for your folder copy? (attach log file to this bug. never
> paste, please) 

Uff - will try with some dummy data.


> > https://wiki.mozilla.org/MailNews:Logging
> > http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25328
> > NSPR_LOG_MODULES=timestamp,imap:5
> 
> > After I delete Äxyz.msf and Äxyz.sbd
> 
> Tb looks to use folder name & file name in windows-1252 or something else. 
> As non-ascii folder name character is passed in modified UTF-7 if IMAP, problem
> like this bug usually won't occur, if "create folder of Äxyz" is requested via
> UI.
> Does "new folder, Äxyz" at the IMAP account work? 

The folder is created at the IMAP side. However, no messages are copied and the whole copy process stops at this point.

> If yes, what is displayed at 
> Location: of folder properties of created IMAP folder of Äxyz?

Will look (other computer, at home -- that's the whole reason why I move that stuff to IMAP).


> What is charset in locale related setting of your Linux? UTF-8? Or other?

I think UTF-8, but will check.
(Reporter)

Comment 3

6 years ago
Could not reproduce - I guess it had something to do with legacy encoding for local folders ...

I just had some strange effects when I deleted (moved to Trash) two folders both called "äöü" - but those were temporary ...
(Reporter)

Comment 4

6 years ago
Resolved as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.