Default domain adds to mailing list.

VERIFIED FIXED in mozilla0.9.1

Status

P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: skasinathan, Assigned: hewitt)

Tracking

Trunk
mozilla0.9.1
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

18 years ago
steps:
1. Compose a msg. I typed 'qa' in the address to bring up the autocomplete pop 
up. I used the _Up and Down_ arrow in keyboard to select a particular Mailing 
list. Jeez, it adds the default domain name to the mailing list, something like 
'qatest37andsuresh<37andsuresh>@netscape.com'.  The mail didn't go tgh, bounced 
back :(

Note: If I use the mouse to select a mailing list in the autocomplete popup then 
default domain is NOT added.
(Reporter)

Updated

18 years ago
QA Contact: esther → suresh
accepting...
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
*** Bug 57180 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: suresh → pmock

Comment 3

18 years ago
Marking nscatfood because I'm relying on the address picker to determine the 
address. Pressing enter should not append the default domain making the message 
fail to send.
Keywords: nsCatFood

Comment 4

18 years ago
*** Bug 68874 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
*** Bug 66066 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
this problem has been fixed. No longer adds domain name to the list.
Linux (2001-04-12-05 trunk)
Win32 (2001-04-12-06 trunk)
Mac (2001-04-12-04 trunk)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
QA Contact: pmock → fenella
Resolution: --- → FIXED

Comment 7

18 years ago
.
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Linux (2001-04-16-10 trunk)
Win32 (2001-04-16-06 trunk)
Mac (2001-04-16-04 trunk)
this bug comes back. Re-open it.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 9

18 years ago
Using build 2001-04-25 on win, mac & linux this is still a bug and fails on our
Basic Functional Test.  I'm going to mark it nsbeta1, because of this a user
cannot mail a msg to list.  No workaround.
Keywords: nsbeta1

Comment 10

18 years ago
marking nsbeta1+
Keywords: nsCatFood → nsCatFood+
Priority: P3 → P2
Whiteboard: [nsbeta1+]
Target Milestone: Future → mozilla0.9.1
(Reporter)

Comment 11

18 years ago
Reassigning to myself.
Assignee: ducarroz → suresh
Status: REOPENED → NEW
(Reporter)

Comment 12

18 years ago
Allright! After debugging more into this (as the one who filed this bug
originally) this bug was only about adding the default domain name to the list.
If you remove the default domain name ('@netscape.com' or whatever) the mail
would be sent to all the recepients in the list.  But now that has regressed and
I filed a new one bug 78410. 

And btw, Joe Hewitt fixed the original problem (adding the default domain name
to the list when selected using _keyboard_, NOT mouse) as part of the new theme
he landed yesterday. Thanks Hewitt!!
Assignee: suresh → hewitt
(Reporter)

Comment 13

18 years ago
Marking fixed based on the above comments.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
Linux (2001-04-16-10 trunk)
Win32 (2001-04-16-06 trunk)
Mac (2001-04-16-04 trunk)
This is ok now.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.