SM hangs after about 6-8 hours of use, Windows Vista SP2

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Pat Welch, Unassigned)

Tracking

({hang})

SeaMonkey 2.0 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: add-on: zonealarm or AVG)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100104 SeaMonkey/2.0 Firefox 3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100104 SeaMonkey/2.0

1) The Seamonkey browser stops working after running around 8 hours
2) It stops on random sites, including sites that I visit all the time
3) It does not stop at the same site(s)
4) Closing all visible Seamonkey Windows results in a *completely* unkillable hidden Seamonkey process that prevents re-launching SeaMonkey (Complaining Seamonkey is already running)
5) Seamonkey apparently thinks it has NOT crashed and therefore can NOT generate a crash report ...
6) I can run the IE 8 browser with no problems while Seamonkey has it's head buried in the sand, suggesting nothing is wrong with my ISP (Comcast) or my internal network or my firewall/router or my AV (Grisoft).
I'm on 32-bit Windows Vista SP2 running on an HP notebook with the AMD Turion dual-core chip, 3 GB RAM. SM 2.0.2.

Reproducible: Sometimes

Steps to Reproduce:
1.Boot the system
2.SM loads automatically
3.Keep using SM for around 8 hours, suddenly the browser thinks it's loaded pages but nothing appears but the "Done" notice in the lower right area.
Actual Results:  
See the Details

Expected Results:  
Should be able to run indefinitely with no problems. I did not have this problem with 1.18, and often let it and the computer run for days.

I have no clue how to get more info on this for you - closing all SM windows leaves behind an UNkillable instance of SM that is only visible by running Task Manager. SM does not appear to realize it has crashed so no crash report is generated, Vista does not complain about the unkillable SM.
Component: www.mozilla.org → General
Product: Websites → SeaMonkey
QA Contact: www-mozilla-org → general
(Reporter)

Updated

9 years ago
Version: unspecified → SeaMonkey 2.0 Branch

Comment 1

9 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7)
> Gecko/20100104 SeaMonkey/2.0 Firefox 3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7)
> Gecko/20100104 SeaMonkey/2.0

I don't think we should even try to support builds with forged strings like those.
(Reporter)

Comment 2

9 years ago
nonsense. I added Firefox 3 in response to suggestions on the SM NG because of a Web site that had to be spoofed or it would not even be loaded. And how does that excuse SM's extremely bad behavior in producing an unkillable instance that requires re-booting to start using SM again?

Comment 3

8 years ago
"stops working" and other things you wrote suggest this is a hang and not a crash, so I have adjusted the bug accordingly. If that is not the case please correct me.

 Two things need clarification:
1. describe in more detail "1) The Seamonkey browser stops working". Is there network activity, is CPU high low or zero, does it happen if SM is started in safe mode (i.e. -safe-mode on commandline), does it happen with antivirus and firewall software disabled?
2. Assuming you can't kill the process at 4) using task manager's "End Process", are you able to kill it using "End Process Tree"?

Note: The element of randomness and the fact that you can't kill the process suggests the cause may be external software or a hardware problem.
Keywords: hang
Summary: SM crashes silently after about 6-8 hours of use, Windows Vista SP2 → SM hangs after about 6-8 hours of use, Windows Vista SP2
(Reporter)

Comment 4

8 years ago
Thanks for looking at this.

It has become worse, stopping after only an hour or so sometimes. Something in 2.0.3 perhaps exacerbated the problem.

The symptoms:

1) After using the browser 'for a while', suddenly attempts to get to web pages shows a blank page, and the word "Done" is displayed in the lower left status area. It stops  working at random web sites, no pattern to it that I can see.

There might(?) be a relationship between clicking on URL's embedded in Emails and going to a web site, but I can't demonstrate a definite causal relationship. It also seems to be more likely to occur when I have been jumping around tracking down info after googling a subject, jumping to a web site, then back to the Goggled search page, jumping off again etc.

2) Another new symptom - when the browser stops working, now Email also stops being able to access my mail ISP's. Before Email continued to work, only the browser was dead.

3) The Seamonkey process becomes completely unkillable, this symptom becomes evident when all 'visible' Seamonkey windows are closed. Trying to launch Seamonkey again gets a dialog box that says Seamonkey is already running, and to close all instances or re-boot. The Task Manager still shows an active SM process.

I have sat and tried 20 times in a row to kill the Seamonkey process in the Task Manager, and also tried the same number of times to kill the process tree, and tried mixing process kills with process tree kills - no joy. Re-booting was the only way to get my Email and Browsing back.

I guess this would be considered a hang rather than a crash, but it's a serious hang in the windows kernel space, I think, perhaps waiting for an interrupt that never comes.

When it happens, I can launch IE 8 and browse the internet W/O any problems, so network/ISP problems would seem to be ruled out.

NO other program that I run has a similar problem (unkillable), the hardware is an HP AMD dual core notebook about 7 months old, has 3 GB RAM, running 32-bit Vista Home Premium and it has never had a hardware problem since I took it out of the box.

I run both AVG and Ad-Aware AV/AS with a Zone Alarm firewall behind a Dlink 8-port firewall/router. I'm not interested in killing my AV for testing, sorry. No other app has a problem with AVG/AW.

My ISP is Comcast, running 16-20 Mbps down and 3-4 Mbps up where I'm located. Maybe the fast speed has an effect on the problem?

This problem had become so bad, and until your Email no one had taken an interest, so I've reluctantly abandoned SeaMonkey and switched to Firefox 3.6 and Tbird 3.0.3.

Both programs have worked flawlessly since I installed them Sunday - no hangs after any amount of time.

SM is still installed, so I can try testing/trying things for you.

Thanks again for looking at this problem.

Comment 5

8 years ago
When it hangs, is it busy or is it idle?
(Reporter)

Comment 6

8 years ago
I didn't think to check the processor % busy graph, but system response felt normal, other processes launched and ran at normal speeds.

It does take a very long time to finish shutting down with SM non-responsive when I finally reboot - 10 times longer than normal at least.

Comment 7

8 years ago
(In reply to comment #4)
> It has become worse, stopping after only an hour or so sometimes. Something in
> 2.0.3 perhaps exacerbated the problem.
> ...
> I run both AVG and Ad-Aware AV/AS with a Zone Alarm firewall behind a Dlink
> 8-port firewall/router. I'm not interested in killing my AV for testing, sorry.

If you have VISTA firewall enabled you are well enough protected to turn off ZA for a short enough period to determine whether they are causing this excruciating problem. ditto AVG, especially if you are not opening email attachments.  firewall, etc are the foremost cause of connectivity problems. Mind, I'm not claiming it is the cause of your problem, just, the probability is very high and normally the first thing that should be checked.


> No other app has a problem with AVG/AW.

the fact that other apps don't have problems with this SW literally means *nothing*, zero, nada, in terms of whether these packages are causing problems with seamonkey. sounds counterintuitive, but regardless, it's true.

Comment 8

8 years ago
Can you try running SeaMonkey in safe mode? from the command line it is "seamonkey.exe -safe-mode". There should also be a menu item in Start->Programs->Mozilla->SeaMonkey->SeaMonkey (safe mode). Do you still get these hangs with SeaMonkey running in this manner?

Do you have any extensions installed? Go to Tools->Addons, then go to the "Extensions" tab. Highlight each row and disable all extensions. If this stops the hangs then re-enable your extensions one by one until the problem comes back.
(Reporter)

Comment 9

8 years ago
sorry for the late response.

I've gone to the trouble of converting to Firefox and Tbird, since the problem became acute enough it was affecting my consulting business and until recently I had absolutely no help with the problem.

FF was fine for several days, then started the same unkillable hang problems as SM. I finally installed Kaspersky security suite, which insisted on de-installing both AVG and ZoneAlarm before it would install itself. The unkillable hangs immediately ceased, and there have been no problems the past 20 days.

So either AVG or ZA in Vista were causing the unkillable hangs in both SM and FF. They share the same engine, so it makes sense both would be affected.

I still have SM installed on my Vista machine, but never use it now. SM on my Ubuntu server never had the problem, so something in the Windows Gecko code on some condition with either AVG or ZA installed is the problem.

The engine code probably should be looked at with an eye to preventing the deadly unkillable failures I saw - even if ZA is the cause, ZA never caused any other browser programs similar problems, including Opera, IE 8 and SM 1.18.

Meaning the other browsers handled whatever ZA was doing and SM 2.x and FF do not.

Comment 10

8 years ago
(In reply to comment #9)
> The engine code probably should be looked at with an eye to preventing the
> deadly unkillable failures I saw - even if ZA is the cause, ZA never caused any
> other browser programs similar problems, including Opera, IE 8 and SM 1.18.
> 
> Meaning the other browsers handled whatever ZA was doing and SM 2.x and FF do
> not.

you still have the situation reversed. it is totally ZA and the others at fault and that need fixing. closing INVALID, caused by other software

thanks for updating the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Whiteboard: add-on: zonealarm or AVG
(Reporter)

Comment 11

8 years ago
I disagree that it's INVALID ...

The other major browsers are NOT affected. That DOES matter. So you are saying the error catching code in SM/FF is so bad it can't handle what the other major browsers (including SM 1.18 I note again) CAN? In fact they handle it so well there's NEVER A HINT OF A PROBLEM?

Perhaps SM and FF respond incorrectly to some boundary condition presented by ZA, putting the problem right back in SM's lap I think.
(Reporter)

Comment 13

8 years ago
Your own SM 1.18 NEVER NEVER had the problem, SM 2.x and FF 3.X does.

SAME version of ZA, I can run 1.18 all day long. Launch SM 2.x/FF 3.x, totally un-killable browser within an hour, sometimes within minutes.

But it's not your code - no siree.

I give up.
You need to log in before you can comment on or make changes to this bug.