Composer: Disappearing numbered list with outdent

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Becki Sanford, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.2
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [list][QAHP] fix in hand, need a=)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When using the E-Mail composer, if you indent a numbered list several levels and
then outdent it, the numbered list aspect disappears.  (Build ID 2000091312)
reassign to editor team.
Assignee: ducarroz → beppe
adding myself to the cc list.

becki:  thanks for following up and logging the bug.

Comment 3

17 years ago
yes, that is by design -- outdenting to the left margin is the mechanism for
escaping out of a list. If you outdent to the left margin, you exit out of the
<li> and <UL>/<OL> and the text becomes plaintext. Another mechanism to exit out
of lists is to set the caret at the end of a list item and hit return twice.
That is the solution for those instances when you are entering list items and
want to move on to entering more bodytext.

If something else occurred, please reopen the bug and explain in detail exactly
what you are doing -- I really need to be walked through what you are doing to
better understand the issues.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
VERIFIED INVALID.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
As per suggestion, I'm reopening this bug and providing a more detailed
description of the actions I'm performing.  I retested with nightly build
2001010321 (i686 pc Linux) and the same problem occurs.  Here is the sequence of
steps that I'm using:

1. Open E-Mail
2. Click on "New Msg" button on the toolbar
3. Click on the numbered list button (1/2/3)
4. Start typing some text
5. Click on the indent text (move right) button SEVERAL times (i.e. indent more
than once)
6. Click on the outdent text (move left) button ONCE

At this point, the text is still indented several levels but the numbered list
aspect disappears.  The number list should remain until the last level of
indentation is removed.  (Sidenote: Netscape 4.75 actually retains the numbered
list no matter what level of indentation.)
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 6

17 years ago
If you entered only one list item, or if you have several list items and 
highlight all of the list items and do the same steps you will also lose the 
numbers. Assigning to jfrancis to see if there is something that can be done to 
preserve the list item on outdent -- maybe until outdented to the leftmost 
position.
Assignee: beppe → jfrancis
Status: REOPENED → NEW
(Assignee)

Comment 7

17 years ago
although this is working as designed, I agree the behavior is odd.  It's really 
what comes from overloading the outdent method to mean different things depending 
on if you are in a list or not.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 8

17 years ago
related bug see bug 57715, that one is probably a dup of this one

Comment 9

17 years ago
*** Bug 66563 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Component: Composition → Editor
Product: MailNews → Browser
Target Milestone: Future → ---
(Assignee)

Comment 10

17 years ago
moving misc editor bugs into browser product

Comment 11

17 years ago
setting this to moz0.9.1
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
Whiteboard: [QAHP]

Comment 12

17 years ago
Yep, this is real. the <UL> is being changed into a <blockquote> when
undenting.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 13

17 years ago
this is easily reproducible, keeping at moz0.9.2 per triage meeting

Updated

17 years ago
Whiteboard: [QAHP] → [list][QAHP]
(Assignee)

Comment 14

17 years ago
Created attachment 38714 [details] [diff] [review]
editor/base patch
(Assignee)

Comment 15

17 years ago
This patch fixes this bug and several others.  outdent is pretty much rewritten
and is much much smarter.  In addition, problems with getting too many or not
enough breaks when unlisting or outdenting have been fixed by this patch.

need r=,sr=
Whiteboard: [list][QAHP] → [list][QAHP] fix in hand, need r=,sr=
(Assignee)

Comment 16

17 years ago
this patch is superceded by patch in bug 62347.
(Assignee)

Comment 17

17 years ago
r=fm; sr=kin; need a=
Whiteboard: [list][QAHP] fix in hand, need r=,sr= → [list][QAHP] fix in hand, need a=
a=blizzard on behalf of drivers for the trunk
(Assignee)

Comment 19

17 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
Using builds 2001-06-28 on win98, mac and linux and the scenario stated on
2001-01-04 this is fixed for the Mail compose window.  I briefly tested this in
composer too using the same scenario.  reassigning QA to sujay for the composer
to see if he wants to do more composer testing.
QA Contact: esther → sujay

Comment 21

17 years ago
okay this works now, marking verified fixed...tried on two platforms: Windows
and Linux using 6/28 builds.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.