Closed Bug 545436 Opened 11 years ago Closed 11 years ago

A11y should avoid caching the focused node.

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 495624

People

(Reporter: davidb, Unassigned)

Details

Why don't we use nsDocument::GetActiveElement?

In any event we should investigate when our cached node is different from what this API gives us. For cases it should be the same we should add test coverage.

Note Enn comments in our code:

NS_IMETHODIMP nsDocAccessible::GetFocusedChild(nsIAccessible **aFocusedChild)
{
  // XXXndeakin P3 accessibility shouldn't be caching the focus
it's a dupe of existing bug
Right you are!
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495624
You need to log in before you can comment on or make changes to this bug.