Fixed background jumps when scrolling up in page with frames.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Justin, Unassigned)

Tracking

3.6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

Only see this issue in Firefox for Windows, other browsers and Firefox for Mac are unaffected. 

When scrolling inside a framed page with a fixed background (CSS- background-position:fixed;) the background flickers as it jumps to re-position itself back at the top of the page.  I reported this as an error because I didn't see any other browser render it this way INCLUDING Firefox for Mac.   

Reproducible: Always

Steps to Reproduce:
1.Go to http://newcocoon.com/
2.Scroll down

Actual Results:  
The "fixed" background flickers as it repositions itself to the top of the page each click of the mouse wheel, making the background appear to shake. 

Expected Results:  
Background should remain "fixed" and content within the frame should move smoothly over it.   Visit http://newcocoon.com/ in another browser, to see the change.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9pre) Gecko/20100209 Shiretoko/3.5.9pre

I can indeed reproduce this, but there is good news: it is fixed in the latest Firefox release, Firefox 3.6: http://www.mozilla.com/en-US/
Resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.