Crash in gkhtml.dll (nsFrameImageLoader.cpp) when browsing amazon.com

VERIFIED DUPLICATE of bug 53317

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 53317
18 years ago
14 years ago

People

(Reporter: dbragg, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Verify once 53317 is fixed, URL)

(Reporter)

Description

18 years ago
Seamonkey crashes when viewing selections in http://www.amazon.com.

To reproduce:
1. Do not run netscape6.exe or mozilla.exe in the debugger.  It's ok to run a
debug version but just don't start it in the debugger itself.  Double click the
icon.
2. Go to www.amazon.com
3. Select one of the little quick picks from the first page. (or any DVD or CD
or whatever).

When running a debug version (again, NOT in the debugger itself) I clicked on
cancel "to debug the app" and it dropped me into nsFramImageLoader.cpp on line
567.  The statement reads:

if(pfd->mCallback)  blah blah...

The problem is that pfd was either never initialized (unlikely) or was
previously destroyed.

Comment 1

18 years ago
could you get a talkback build and reproduce this with it?  That would help us a
lot.  I assume you are using the ns6beta3 branch?

Comment 2

18 years ago
i think this is a duplicate of bug 53317 -- both involve a problem with pfd, 
both are in nsFrameImageLoader.  However, according to this bug, it's in line 
567, but in the stack over there it says 560.  Still, pretty sure it's a dup -- 
a stack trace would tell for sure.

*** This bug has been marked as a duplicate of 53317 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
Talkback report is 
Incident ID: 18217421
(Assignee)

Comment 4

18 years ago
stack trace from talkback report
http://climate/reports/incidenttemplate.cfm?bbid=18217421

ns_observer_proc
[d:\builds\seamonkey\mozilla\gfx\src\nsImageRequest.cpp,line135]
XP_NotifyObservers
[d:\builds\seamonkey\mozilla\modules\libutil\src\obs.c,line260]
il_image_complete_notify
[d:\builds\seamonkey\mozilla\modules\libimg\src\if.cpp,line329]
il_image_complete
[d:\builds\seamonkey\mozilla\modules\libimg\src\if.cpp,line1653]
ImgDCallbk::ImgDCBHaveImageAll
[d:\builds\seamonkey\mozilla\modules\libimg\src\if.cpp,line191]
process_buffered_gif_input_data
[d:\builds\seamonkey\mozilla\modules\libimg\gifcom\gif.cpp,line694]
gif_delay_time_callback
[d:\builds\seamonkey\mozilla\modules\libimg\gifcom\gif.cpp,line728]
timer_callback
[d:\builds\seamonkey\mozilla\gfx\src\nsImageSystemServices.cpp,line72]
nsTimer::Fire
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp,line196]
nsTimerManager::FireNextReadyTimer
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimerManager.cpp,line117]
nsAppShell::Run
[d:\builds\seamonkey\mozilla\widget\src\windows\nsAppShell.cpp,line116]
0x04d62a0c
0x04d65fdc

Comment 5

18 years ago
verify this once bug 53317 is fixed
Whiteboard: Verify once 53317 is fixed

Comment 6

18 years ago
Bug 53317 is now fixed, and Amazon is now behaving properly with:
- Linux build 2000110921
- Win98 build 2000111004
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.