If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tab context menu should not show when right-clicking all tabs menu items

VERIFIED WORKSFORME

Status

()

Firefox
Tabbed Browser
VERIFIED WORKSFORME
8 years ago
4 years ago

People

(Reporter: fryn, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

489 bytes, application/x-javascript
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.78 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

It has already been established in comments for other bugs that the all tabs menu should just be a simple menu. Because of this, in Firefox 3.5 and below, the all tabs menu items did not have a context menu.

However, Firefox 3.6 broke this. Now the all tabs menu items do produce the tab context menu, but selecting an item from the tab context menu does not apply it to the item that was right-clicked. Instead it applies it to the selected tab.

This is very confusing to the users and should be fixed.

Reproducible: Always

Steps to Reproduce:
1. Open the all tabs menu popup.
2. Right-click an item.
Actual Results:  
Tab context menu appears.

Expected Results:  
It should not appear.

This is a REGRESSION.
(Reporter)

Comment 1

8 years ago
Created attachment 426456 [details]
userChromeJS workaround
(Reporter)

Updated

8 years ago
Keywords: regression
(Reporter)

Comment 2

8 years ago
By the way, this regression appears in both Firefox 3.6 and the trunk (3.7a1, etc.)

I have not been able to find the regression window, but the bug seems easy enough to fix, given that I have already put together a completely functioning workaround.
Version: unspecified → Trunk
See also bug 538812. Dao, is that context menu wanted or not?
(Reporter)

Comment 4

8 years ago
I can't find the exact bug in which it was mentioned, but I do remember that there was a bug requesting that the all tabs menu be more powerful and be able to close tabs and perform other tab-specific actions, but it was determined that the all tabs menu was to be just a simple, tab-selecting menu without a context menu.

Depending on what the current consensus is, bug 356980 should either be marked WONTFIX, or work should start on the that bug.
(Reporter)

Comment 5

8 years ago
Is the regression window wanted, or is this simply going to be part of the next tabbed browsing rewrite for Firefox 4?
(In reply to comment #3)
> See also bug 538812. Dao, is that context menu wanted or not?

Dao, do you have an answer for us?
(Reporter)

Comment 7

7 years ago
Turning the tab bar into a toolbar fixed this issue.

Now the toolbar context menu is shown on Windows and Linux, but that'll be another bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: regression
Resolution: --- → WORKSFORME
(In reply to comment #3)
> See also bug 538812. Dao, is that context menu wanted or not?

No, it's not wanted.

Updated

7 years ago
Duplicate of this bug: 538812
Verified with builds on all platforms like Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.