Add popular German ISPs online.de and arcor.de

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: BenB, Assigned: BenB)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.31 KB, application/xml
bwinton
: review+
gozer
: review+
Details
1.38 KB, application/xml
bwinton
: review+
gozer
: review+
Details
(Assignee)

Description

9 years ago
online.de and arcor.de are at the top of the list of domains requested, but not on our config server. I created configs for them.

arcor.de is verified (based on support pages and manual probing) and works (tested with a free account).

online.de is confirmed with their support, but the SMTP server doesn't react with netcat and I haven't gotten a test account yet.
(Assignee)

Comment 1

9 years ago
Created attachment 426496 [details]
arcor.de
Assignee: nobody → ben.bucksch
Status: NEW → ASSIGNED
Attachment #426496 - Flags: review?(bwinton)
(Assignee)

Comment 2

9 years ago
Created attachment 426497 [details]
online.de (1&1)
(Assignee)

Updated

9 years ago
Attachment #426497 - Attachment mime type: application/octet-stream → application/xml
Comment on attachment 426496 [details]
arcor.de

It passes the sanity checks, uses secure ports, and works with my copy of Lanikai.

I'm happy.  :)
Attachment #426496 - Flags: review?(bwinton) → review+
(Assignee)

Updated

9 years ago
Attachment #426496 - Flags: review?(gozer)
(Assignee)

Comment 4

9 years ago
Comment on attachment 426497 [details]
online.de (1&1)

unfortunately, the SMTP server apparently only works within the ISP network. It says 220 Welcome, but doesn't respond to EHLO at all, I tried from 2 different networks. I spoke with support and telnet+EHLO works for them from their network, so apparently it's an IP-based block. I'm trying to find a better config, but that seems to be the best current one.
Attachment #426497 - Attachment description: online.de (1&1) - not yet tested → online.de (1&1) - not yet tested, SMTP server only works within the ISP network
(Assignee)

Comment 5

9 years ago
(last comment is about online.de.
arcor.de is fine)
Attachment #426496 - Flags: review?(gozer) → review+
(Assignee)

Comment 6

9 years ago
Comment on attachment 426497 [details]
online.de (1&1)

I checked with 1&1 about the SMTP server, and it works with telnet (even outside the ISP network), just not with netcat (no idea why, this is the first time I had that).
So, it was just bad testing on my side. Config should work.
I still don't have a test account, but it should work as-is. Please review.
Attachment #426497 - Attachment description: online.de (1&1) - not yet tested, SMTP server only works within the ISP network → online.de (1&1)
Attachment #426497 - Flags: review?(bwinton)
(Assignee)

Updated

9 years ago
Attachment #426497 - Flags: review?(gozer)
Comment on attachment 426497 [details]
online.de (1&1)

Tested connectivity and certificates.
Attachment #426497 - Flags: review?(gozer) → review+
(Assignee)

Comment 8

9 years ago
1&1 (online.de) provided me with a test account, and the config worked (IMAP and SMTP).
Comment on attachment 426497 [details]
online.de (1&1)

My only question is "Why isn't 1und1.de in the list of domains?".

Other than that, r=me.

Thanks,
Blake.
Attachment #426497 - Flags: review?(bwinton) → review+
(Assignee)

Comment 10

9 years ago
> Why isn't 1und1.de in the list of domains?

Because they don't hand that out to customers, they are the corporate/employee accounts and probably use different servers.

Thanks.
(Assignee)

Comment 11

9 years ago
Committed revision 63366.
FIXED.

Thanks all!
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Uh, didn't you forget to add the files:
onlinehome.de, sofortstart.de, sofort-start.de, sofortsurf.de, sofort-surf.de, and go4more.de?

(Next time, I'm insisting on a patch instead of a sample XML file. ;)
And arcor.de?
(Assignee)

Comment 14

9 years ago
> didn't you forget to add the files: onlinehome.de

Thanks for the catch! Commited them now.

> (Next time, I'm insisting on a patch instead of a sample XML file. ;)

Nah, commit errors can happen regardless.

> And arcor.de?

r62167 | ...bucksch.org | 2010-02-12 02:16:04 +0100 (Fr, 12 Feb 2010) | 2 lines
adding arcor, r=bwinton, r=gozer, bug 545646
(Assignee)

Updated

9 years ago
Summary: Add some ISP configs, esp. German popular ones: online.de and arcor.de → Add popular German ISPs online.de and arcor.de
Component: ispdb → ISPDB Server
Product: Mozilla Messaging → Webtools
You need to log in before you can comment on or make changes to this bug.