If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Delete buttons missing/disabled in when opening message in existing window

RESOLVED DUPLICATE of bug 254386

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 254386
8 years ago
7 years ago

People

(Reporter: Marc Neuberger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0.1 (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1)

I have TB configured to open messages in an existing message window.

When I open a message and there /is/ an existing window, the window has the following quirks:

* The "Delete" and "archive" buttons are missing from the message header pane,
* The "Delete" button is disabled in the toolbar,
* Some (maybe all) keyboard shortcuts do not work. In particular, F & B to move forward/backward in the message list do not work.

If I close the message window and reopen the message, everything is fine.

Reproducible: Always

Steps to Reproduce:
1. Tools->Options->Reading & Display, set Open messages in: An existing window
2. Double-click on a message in the message list to open it.
3. Double-click on another message in the message list to replace the first one in the message reading pane.
Actual Results:  
Buttons are missing/disabled.

Expected Results:  
Buttons should be there just as if the message had been opened in a new window.
Confirming on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b2pre Thunderbird/3.0.1 ID:20100111101938 - note also that N and P shortcuts don't work either, nor any of their corresponding menu commands (Go -> {Next|Previous} -> {Message|Unread Message|Starred Message|Unread Thread}), nor even the [ and ] keys (or their Back and Forward commands on the Go menu, either) -- those last are difficult to be sure of testing right now. On the Message menu, Archive and Move to "…" Again are disabled also, and on the Edit menu, Find -> Search Messages… is disabled as well.

This looks like it's related to the underlying cause of bug 522215, but I'm not sure.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86_64 → All
This also sounds somewhat similar to a bug that bienvenu fixed in 3.0.x, I thought.  David, does this ring any bells?

Comment 3

8 years ago
I think that bug fix is stalled on a unit test...
bienvenu: I can't seem to find it amongst the 388 bugs assigned to you.  Can you?

Comment 5

8 years ago
No, I looked earlier but could not find it. Iirc, the fix was easy but the unit test was hard/impossible, so it should be fairly easy to find the fix again.
Duplicate of this bug: 545971
Duplicate of this bug: 548348

Comment 8

8 years ago
This appears to be a duplicate of Bug 254386.
That's close enough, yes, for our purposes; I don't like the long and varied history of bug 254386, but it'll have to do. Later comments in particular are the same as this bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254386
(In reply to comment #9)
> That's close enough, yes, for our purposes; I don't like the long and varied
> history of bug 254386, but it'll have to do. Later comments in particular are
> the same as this bug.
> 
> *** This bug has been marked as a duplicate of bug 254386 ***

I looked at that also, and am unconvinced either way.  I would be cautious about duping to an older bug when the reporter describes what is, for him/her is new behavior - especially when the precise cause of the new bug is unknown.

Comment 11

7 years ago
I installed the buttons addon by changing it to zip, opening install.rtf, and editing the max allowed version, the delete button doesn't work when the conditions for this bug have been met!

Comment 12

7 years ago
Thunderbird 3.1.10 Linux

Have it set to open emails in existing windows.
Double click an email to open in a window
Double click another email, it opens in the existing window
Click my Next button, get below in the error console
Other buttons don't work, my Delete button goes completely disabled

Error: An error occurred executing the button_next command: [Exception... "'[JavaScript Error: "aParent is null" {file: "chrome://messenger/content/msgViewNavigation.js" line: 69}]' when calling method: [nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 96"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 100
You need to log in before you can comment on or make changes to this bug.