Closed Bug 545692 Opened 10 years ago Closed 9 years ago

Crash in mochitest/dom-level1-core/test_hc_namednodemapgetnameditem.html [@ JS_CallTracer] | js_TraceContext | js_TraceRuntime | js_GC

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Attached file Full log
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265900855.1265901773.25022.gz
Linux mozilla-central opt test mochitests-2/5 on 2010/02/11 07:07:35
s: moz2-linux-slave23

5856 INFO Running /tests/dom/tests/mochitest/dom-level1-core/test_hc_namednodemapgetnameditem.html...
TEST-UNEXPECTED-FAIL | automation.py | Exited with code 11 during test run
INFO | automation.py | Application ran for: 0:04:46.800431
INFO | automation.py | Reading PID log: /tmp/tmpwujblApidlog
PROCESS-CRASH | automation.py | application crashed (minidump found)
Operating system: Linux
                  0.0.0 Linux 2.6.18-53.1.19.el5 #1 SMP Wed May 7 08:20:19 EDT 2008 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 8
     1 CPU

Crash reason:  SIGSEGV
Crash address: 0xfc0

Thread 0 (crashed)
 0  libmozjs.so!JS_CallTracer [jsgc.cpp:484a3c2949c2 : 540 + 0x3]
    eip = 0x008b41c6   esp = 0xbfe18664   ebp = 0xbfe186bc   ebx = 0x009bbf9c
    esi = 0x00000008   edi = 0x000003f0   eax = 0x00000000   ecx = 0x00000001
    edx = 0x009bf0b0   efl = 0x00010202
    Found by: given as instruction pointer in context
 1  libmozjs.so!js_TraceContext [jsgc.cpp:484a3c2949c2 : 2487 + 0x1b]
    eip = 0x008b53dc   esp = 0xbfe186c4   ebp = 0xbfe186fc
    Found by: previous frame's frame pointer
 2  libmozjs.so!js_TraceRuntime [jsgc.cpp:484a3c2949c2 : 2520 + 0xb]
    eip = 0x008b57f4   esp = 0xbfe18704   ebp = 0xbfe1873c
    Found by: previous frame's frame pointer
 3  libmozjs.so!js_GC [jsgc.cpp:484a3c2949c2 : 3184 + 0xb]
    eip = 0x008b5f2c   esp = 0xbfe18744   ebp = 0xbfe188ec
    Found by: previous frame's frame pointer
 4  libmozjs.so!_ZL20RefillDoubleFreeListP9JSContext [jsgc.cpp:484a3c2949c2 : 1701 + 0x12]
    eip = 0x008b7b49   esp = 0xbfe188f4   ebp = 0xbfe1894c
    Found by: previous frame's frame pointer
 5  libmozjs.so!js_NewWeaklyRootedDouble [jsgc.cpp:484a3c2949c2 : 1777 + 0xa]
    eip = 0x008b7e99   esp = 0xbfe18954   ebp = 0xbfe1897c
    Found by: previous frame's frame pointer
 6  libmozjs.so!JS_NewDoubleValue [jsapi.cpp:484a3c2949c2 : 1906 + 0x11]
    eip = 0x0086eb38   esp = 0xbfe18984   ebp = 0xbfe1899c
    Found by: previous frame's frame pointer
 7  libmozjs.so!js_NewWeaklyRootedNumber [jsnum.cpp:484a3c2949c2 : 827 + 0x12]
    eip = 0x008cf9d3   esp = 0xbfe189a4   ebp = 0xbfe189cc
    Found by: previous frame's frame pointer
 8  libxul.so!_ZL24DefineInterfaceConstantsP9JSContextP8JSObjectPK4nsID [nsDOMClassInfo.cpp:484a3c2949c2 : 5300 + 0x1e]
    eip = 0x012779ed   esp = 0xbfe189d4   ebp = 0xbfe18a1c
    Found by: previous frame's frame pointer
 9  libxul.so!_ZL16ResolvePrototypeP12nsIXPConnectP14nsGlobalWindowP9JSContextP8JSObjectPKtPK18nsDOMClassInfoDataPK18nsGlobalNameStructP24nsScriptNameSpaceManagerS6_iPi [nsDOMClassInfo.cpp:484a3c2949c2 : 5837 + 0x14]
    eip = 0x01278ab9   esp = 0xbfe18a24   ebp = 0xbfe18a7c
    Found by: previous frame's frame pointer
10  libxul.so!nsDOMClassInfo::PostCreatePrototype(JSContext*, JSObject*) [nsDOMClassInfo.cpp:484a3c2949c2 : 4360 + 0x33]
    eip = 0x01279304   esp = 0xbfe18a84   ebp = 0xbfe18adc
    Found by: previous frame's frame pointer
11  libxul.so!XPCWrappedNativeProto::Init(XPCCallContext&, int, XPCNativeScriptableCreateInfo const*) [xpcwrappednativeproto.cpp:484a3c2949c2 : 143 + 0x12]
    eip = 0x00e3af4a   esp = 0xbfe18ae4   ebp = 0xbfe18b0c
    Found by: previous frame's frame pointer
12  libxul.so!XPCWrappedNativeProto::GetNewOrUsed(XPCCallContext&, XPCWrappedNativeScope*, nsIClassInfo*, XPCNativeScriptableCreateInfo const*, int, int, QITableEntry*) [xpcwrappednativeproto.cpp:484a3c2949c2 : 265 + 0x14]
    eip = 0x00e3b108   esp = 0xbfe18b14   ebp = 0xbfe18b6c
    Found by: previous frame's frame pointer
13  libxul.so!XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, nsWrapperCache*, int, XPCWrappedNative**) [xpcwrappednative.cpp:484a3c2949c2 : 532 + 0x17]
    eip = 0x00e34fe7   esp = 0xbfe18b74   ebp = 0xbfe18c4c
    Found by: previous frame's frame pointer
14  libxul.so!XPCConvert::NativeInterface2JSObject(XPCLazyCallContext&, int*, nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, XPCNativeInterface**, nsWrapperCache*, JSObject*, int, int, unsigned int*) [xpcconvert.cpp:484a3c2949c2 : 1202 + 0x19]
    eip = 0x00e1e7a1   esp = 0xbfe18c54   ebp = 0xbfe18cdc
    Found by: previous frame's frame pointer
15  libxul.so!nsXPConnect::WrapNativeToJSVal(JSContext*, JSObject*, nsISupports*, nsID const*, int, int*, nsIXPConnectJSObjectHolder**) [nsXPConnect.cpp:484a3c2949c2 : 1292 + 0x5]
    eip = 0x00e114ef   esp = 0xbfe18ce4   ebp = 0xbfe18ddc
    Found by: previous frame's frame pointer
16  libxul.so!nsContentUtils::WrapNative(JSContext*, JSObject*, nsISupports*, nsID const*, int*, nsIXPConnectJSObjectHolder**, int) [nsContentUtils.cpp:484a3c2949c2 : 5229 + 0x20]
    eip = 0x010ebcb3   esp = 0xbfe18de4   ebp = 0xbfe18e2c
    Found by: previous frame's frame pointer
17  libxul.so!nsJSContext::ConvertSupportsTojsvals(nsISupports*, void*, unsigned int*, int**, js::LazilyConstructed<nsAutoPoolRelease>&, js::LazilyConstructed<JSAutoTempValueRooter>&) [nsContentUtils.h : 1510 + 0x1a]
    eip = 0x0124cb84   esp = 0xbfe18e34   ebp = 0xbfe18eac
    Found by: previous frame's frame pointer
18  libxul.so!nsJSContext::CallEventHandler(nsISupports*, void*, void*, nsIArray*, nsIVariant**) [nsJSEnvironment.cpp:484a3c2949c2 : 2154 + 0x4]
    eip = 0x0124d9bb   esp = 0xbfe18eb4   ebp = 0xbfe18f5c
    Found by: previous frame's frame pointer

(snipped)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266498844.1266499440.27995.gz
Linux mozilla-central opt test mochitest-other on 2010/02/18 05:14:04
s: moz2-linux-slave23

This occurred in a different test, but the JS engine crash looks the same:

1162 INFO Running chrome://mochikit/content/chrome/content/xul/templates/tests/chrome/test_tmpl_xmlquerywithassign.xul...
NEXT ERROR TEST-UNEXPECTED-FAIL | automation.py | Exited with code 11 during test run
INFO | automation.py | Application ran for: 0:00:24.249109
INFO | automation.py | Reading PID log: /tmp/tmp7DzgiYpidlog
NEXT ERROR PROCESS-CRASH | automation.py | application crashed (minidump found)
Operating system: Linux
                  0.0.0 Linux 2.6.18-53.1.19.el5 #1 SMP Wed May 7 08:20:19 EDT 2008 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 8
     1 CPU

Crash reason:  SIGSEGV
Crash address: 0xfc0

NEXT ERROR Thread 0 (crashed)
 0  libmozjs.so!JS_CallTracer [jsgc.cpp:77dab2533801 : 540 + 0x3]
    eip = 0x0018e1c6   esp = 0xbfa58cf0   ebp = 0xbfa58d48   ebx = 0x00295f9c
    esi = 0x00000008   edi = 0x000003f0   eax = 0x00000000   ecx = 0x00000001
    edx = 0x002990b0   efl = 0x00210202
    Found by: given as instruction pointer in context
 1  libmozjs.so!js_TraceContext [jsgc.cpp:77dab2533801 : 2487 + 0x1b]
    eip = 0x0018f3dc   esp = 0xbfa58d50   ebp = 0xbfa58d88
    Found by: previous frame's frame pointer
 2  libmozjs.so!js_TraceRuntime [jsgc.cpp:77dab2533801 : 2520 + 0xb]
    eip = 0x0018f7f4   esp = 0xbfa58d90   ebp = 0xbfa58dc8
    Found by: previous frame's frame pointer
 3  libmozjs.so!js_GC [jsgc.cpp:77dab2533801 : 3184 + 0xb]
    eip = 0x0018ff2c   esp = 0xbfa58dd0   ebp = 0xbfa58f78
    Found by: previous frame's frame pointer
 4  libmozjs.so!_ZL20RefillDoubleFreeListP9JSContext [jsgc.cpp:77dab2533801 : 1701 + 0x12]
    eip = 0x00191b49   esp = 0xbfa58f80   ebp = 0xbfa58fd8
    Found by: previous frame's frame pointer
 5  libmozjs.so!js_NewWeaklyRootedDouble [jsgc.cpp:77dab2533801 : 1777 + 0xa]
    eip = 0x00191e99   esp = 0xbfa58fe0   ebp = 0xbfa59008
    Found by: previous frame's frame pointer
 6  libmozjs.so!JS_NewDoubleValue [jsapi.cpp:77dab2533801 : 1906 + 0x11]
    eip = 0x00148b38   esp = 0xbfa59010   ebp = 0xbfa59028
    Found by: previous frame's frame pointer
 7  libmozjs.so!js_NewWeaklyRootedNumber [jsnum.cpp:77dab2533801 : 827 + 0x12]
    eip = 0x001a99d3   esp = 0xbfa59030   ebp = 0xbfa59058
    Found by: previous frame's frame pointer
 8  libxul.so!_ZL24DefineInterfaceConstantsP9JSContextP8JSObjectPK4nsID [nsDOMClassInfo.cpp:77dab2533801 : 5300 + 0x1e]
    eip = 0x01278cfd   esp = 0xbfa59060   ebp = 0xbfa590a8
    Found by: previous frame's frame pointer
(snipped)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 560153
Sorry, I duped the wrong bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 568405
Summary: Crash in mochitest/dom-level1-core/test_hc_namednodemapgetnameditem.html [@ JS_CallTracer] → Crash in mochitest/dom-level1-core/test_hc_namednodemapgetnameditem.html [@ JS_CallTracer] | js_TraceContext | js_TraceRuntime | js_GC
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.