Crash in js_GetUpvar on TM Tip

RESOLVED DUPLICATE of bug 545573

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 545573
8 years ago
8 years ago

People

(Reporter: gwagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
For an optimized browser build.
Url: http://www.chromeexperiments.com/detail/canopy/

Process:         firefox-bin [76986]
Path:            /Users/idefix/moz/ws0/obj-ff-opt/dist/Minefield.app/Contents/MacOS/firefox-bin
Identifier:      org.mozilla.firefox
Version:         3.7a2pre (3.7a2pre)
Code Type:       X86 (Native)
Parent Process:  bash [19598]

Date/Time:       2010-02-11 12:41:12.164 -0800
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Interval Since Last Report:          137484 sec
Crashes Since Last Report:           13
Per-App Interval Since Last Report:  752 sec
Per-App Crashes Since Last Report:   3

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000018
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libmozjs.dylib                	0x01681f5d js_GetUpvar + 29
1   libmozjs.dylib                	0x01668e46 js_NewFlatClosure + 182
2   libmozjs.dylib                	0x016786e7 js_Interpret + 27255
3   libmozjs.dylib                	0x01683bb1 js_Execute + 625
4   libmozjs.dylib                	0x01627013 JS_EvaluateUCScriptForPrincipals + 163
5   XUL                           	0x00605028 nsJSContext::EvaluateString(nsAString_internal const&, void*, nsIPrincipal*, char const*, unsigned int, unsigned int, nsAString_internal*, int*) + 504
6   XUL                           	0x0048e412 nsScriptLoader::EvaluateScript(nsScriptLoadRequest*, nsString const&) + 642
7   XUL                           	0x0048f45f nsScriptLoader::ProcessRequest(nsScriptLoadRequest*) + 383
8   XUL                           	0x00490489 nsScriptLoader::ProcessScriptElement(nsIScriptElement*) + 3257
9   XUL                           	0x0048d124 nsScriptElement::MaybeProcessScript() + 292
10  XUL                           	0x00533940 nsHTMLScriptElement::MaybeProcessScript() + 32
11  XUL                           	0x005323ce nsHTMLScriptElement::DoneAddingChildren(int) + 30
12  XUL                           	0x00558b14 HTMLContentSink::ProcessSCRIPTEndTag(nsGenericHTMLElement*, int) + 148
13  XUL                           	0x0055a1f8 SinkContext::CloseContainer(nsHTMLTag, int) + 760
14  XUL                           	0x0055aeed HTMLContentSink::CloseContainer(nsHTMLTag) + 61
15  XUL                           	0x001cd0df CNavDTD::CloseContainer(nsHTMLTag, int) + 271
16  XUL                           	0x001d078d CNavDTD::HandleEndToken(CToken*) + 813
17  XUL                           	0x001cf7db CNavDTD::HandleToken(CToken*) + 1387
18  XUL                           	0x001d0ab2 CNavDTD::BuildModel(nsITokenizer*, int, int, nsCString const*) + 146
19  XUL                           	0x001d8ee1 nsParser::BuildModel() + 145
20  XUL                           	0x001de387 nsParser::ResumeParse(int, int, int) + 279
21  XUL                           	0x001db1cc nsParser::ContinueInterruptedParsing() + 172
22  XUL                           	0x004279f1 nsRunnableMethod<nsContentSink, void>::Run() + 33
23  XUL                           	0x00bc385c nsThread::ProcessNextEvent(int, int*) + 252
24  XUL                           	0x00b82187 NS_ProcessPendingEvents_P(nsIThread*, unsigned int) + 87
25  XUL                           	0x00b2f301 nsBaseAppShell::NativeEventCallback() + 97
26  XUL                           	0x00af14c5 nsAppShell::ProcessGeckoEvents(void*) + 757
27  com.apple.CoreFoundation      	0x9154e8cb __CFRunLoopDoSources0 + 1563
28  com.apple.CoreFoundation      	0x9154c38f __CFRunLoopRun + 1071
29  com.apple.CoreFoundation      	0x9154b864 CFRunLoopRunSpecific + 452
30  com.apple.CoreFoundation      	0x9154b691 CFRunLoopRunInMode + 97
31  com.apple.HIToolbox           	0x989c0f0c RunCurrentEventLoopInMode + 392
32  com.apple.HIToolbox           	0x989c0bff ReceiveNextEventCommon + 158
33  com.apple.HIToolbox           	0x989c0b48 BlockUntilNextEventMatchingListInMode + 81
34  com.apple.AppKit              	0x90c79ac5 _DPSNextEvent + 847
35  com.apple.AppKit              	0x90c79306 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
36  com.apple.AppKit              	0x90c3b49f -[NSApplication run] + 821
37  XUL                           	0x00af0a8a nsAppShell::Run() + 170
38  XUL                           	0x009756f7 nsAppStartup::Run() + 71
39  XUL                           	0x00010c81 XRE_main + 7697
40  org.mozilla.firefox           	0x00001b68 main + 232
41  org.mozilla.firefox           	0x00001a16 start + 54
Brendan, could this be due to your recent patch?
Don't know -- Gregor, can you bisect? Or better yet, extract a testcase?

/be
(Reporter)

Comment 3

8 years ago
Works with current Tip again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545573
You need to log in before you can comment on or make changes to this bug.