[mac]toolbar menubuttons (e.g. back, forward, print) user feedback is broken

VERIFIED FIXED

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: andreww)

Tracking

({classic, regression})

Trunk
PowerPC
Mac System 8.6
classic, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++]Working on Mac now.)

Attachments

(3 attachments)

Classic skin, back and forward buttons:
mouse over the dropmarker, the entire button is highlighted correctly
mouse over the button part itself, only that segment is highlighted, rather than 
raising the dropmarker with it. this is a problem. to see how it is supposed to 
work, you have to flip the pref on joki's hierachical :hover stuff. 

The back and forward menubuttons in classic are dependant on particular aspects 
of :hover behaviour that changed in joki's 09/14 checkin. The menubuttons were 
updated to work with joki's change, however this change was reverted and the 
menubuttons are broken again. 

The fix for this is to revert my changes for compliance with the hierachical 
:hover, and apply a robustness tweak to it to ensure it works identically with 
either system. (I would, however, appreciate some sort of consensus about how 
this is going to end up working so I don't end up scrambling to support one 
system or another).

This is a very obvious bug as it deals with the primary navigation buttons in 
Navigator.
nominating for rtm. 
Status: NEW → ASSIGNED
Keywords: classic, correctness, rtm
Priority: P3 → P1

Comment 2

17 years ago
Yes, let's fix this in RTM.  It's annoying this regressed the last week.  Ben's
change basically rolls the problem file back a revision.
Keywords: regression
Whiteboard: [rtm+] fix being reviewed

Comment 3

17 years ago
Ooops, this is a P2.
Priority: P1 → P2

Comment 4

17 years ago
*** Bug 54863 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
PDT marking [rtm need info] since no patch or code review are available
Whiteboard: [rtm+] fix being reviewed → [rtm need info] fix being reviewed
Created attachment 16163 [details] [diff] [review]
menubutton.css changes
Created attachment 16164 [details] [diff] [review]
menulistBindings.xml changes
patches look lengthy but it basically involves rolling the two files back two 
revs to get the old behaviour before I made the change. That code was well 
tested. I added a couple of !importants to :active rules on the buttons as well 
so that this code now works no matter how the hierachical hover pref is set. 
Keywords: review

Comment 9

17 years ago
r=blake on the patch (mainly just a reversion), with the obligatory note that 
most of this is a hack (since the fix for 5693 was turned off by default), and 
the added caveat that I could only test the patches on windows.

Comment 10

17 years ago
rtm+ now because it's reviewed and approved.
Whiteboard: [rtm need info] fix being reviewed → [rtm+] Fix in hand, reviewed and approved
hyatt sez a=hyatt for this. 
Whiteboard: [rtm+] Fix in hand, reviewed and approved → [rtm need info] fix being reviewed
unclobbering the rtm+
Whiteboard: [rtm need info] fix being reviewed → [rtm+] fix being reviewed
Whiteboard: [rtm+] fix being reviewed → [rtm+]

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [rtm+] → [rtm+]Fix in hand, reviewed and approved

Comment 13

17 years ago
PDT marking [rtm++] especially for the stretched icon problem.
Whiteboard: [rtm+]Fix in hand, reviewed and approved → [rtm++]Fix in hand, reviewed and approved
fix checked in on branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
These stretched buttons are still a problem on Mac.  Win32 looks good.
reopening for the mac issue
OS: All → Mac System 8.6
Hardware: All → Macintosh
.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
andrew was working on a fix for this. 
Assignee: ben → andreww
Status: REOPENED → NEW
(Assignee)

Comment 19

17 years ago
I'm basically taking the windows changes wholesale, but there are some additional 
work to get them looking right on mac.

Looking into this now... I seem to crash when I choose a dropdown which is 
disabled.
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Summary: toolbar menubuttons (e.g. back, forward, print) user feedback is broken → [mac]toolbar menubuttons (e.g. back, forward, print) user feedback is broken
(Assignee)

Comment 20

17 years ago
*** Bug 55908 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
*** Bug 55889 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

17 years ago
Since this is a reopenage and just on mac should I clear the status whiteboard?
Whiteboard: [rtm++]Fix in hand, reviewed and approved → [rtm++]Working on Mac now.
(Assignee)

Comment 23

17 years ago
Created attachment 16718 [details] [diff] [review]
2 files for mac bug. buttonbindings.xml, menubutton.css
(Assignee)

Comment 24

17 years ago
r=hewitt. seeking sr.
a=ben
(Assignee)

Comment 26

17 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 27

17 years ago
marking verified on mac (2000-10-11-10-MN6).
Status: RESOLVED → VERIFIED

Comment 28

17 years ago
Marking verified on Mac (2001-01-02-08-Mtrunk).
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.