is the Personas rollover feature on First Run broken?

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: jslater, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
I'm getting some reports that the Personas rollover feature on the First Run page may not be working. 

Here's a quote from cbeard:
"it looks like the persona-preview on mouseover doesn't seem to work. odd in that it works for me with https (https://www.mozilla.com/en-US/firefox/3.6/firstrun/) but not http

also, i don't see the add-on promo with the http version
i also flushed my cache and tried a unique url to see if it was an edge serving issue
http://www.mozilla.com/en-US/firefox/3.6/firstrun/?blah"

and another quote from Pascal:
"This seems to be a weird bug - Sean Martell just reported that the whole mouse-over thing never worked on one profile, but works perfectly well on another profile he has..."

For the record, the rollover works fine for me on http and https. But, it'd be great to investigate this further.
Works for me.
(Reporter)

Comment 2

9 years ago
Is anyone else having this problem?
Sean Martell can definitely replicate this with one of his Fx profiles. It works fine in a different profile.
(Reporter)

Comment 4

9 years ago
Copying Sean...

Comment 5

9 years ago
Hey, yes for some reason my default profile doesn't work with the rollover, but if I create a new profile, it works.

Perhaps others who have the issue should test and create a new profile to check to see if that fixes it for them as well?

Not sure of the actual problem, and my method is not a solution, but I did notice that it worked.
I can't reproduce this in neither current profiles nor a clean one, but a couple possibilities exist:

A) Is it possible that our CDN (EdgeCast) was in the process of origin pull (where it pulls and caches our CSS, images, and JS), and stored the old version and the ETag [1] was wrong?

B) The other possibility is that our expires headers were wrong

Alex and Ryan would have a better idea than I as to whether either would be probable causes; Ryan, you're the guy who knows the most about our YSlow! support on Mozilla.com; any ideas?

Can those whom still experience this do some minor debugging through Live HTTP Headers and/or Firebug?
(In reply to comment #6)
> A) Is it possible that our CDN (EdgeCast) was in the process of origin pull
> (where it pulls and caches our CSS, images, and JS), and stored the old version
> and the ETag [1] was wrong?

The firstrun page on getpersonas.com doesn't use any far-future expires header caching, so the files can't be cached. They get refreshed pretty often (probably every min or less).

> B) The other possibility is that our expires headers were wrong

Same as A, no expires headers = no caching.

The promos for the firstrun page aren't related to getpersonas.com, that can be a separate bug.

Sean: what add-ons are installed in the profile that doesn't work? Adblock Plus has been known to block js on getpersonas.com
Some users have reported the same issue on the MozillaZine.jp forum. He/she resolved this by creating a new profile and coping its permissions.sqlite onto the default profile.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.