Double accesskey 'n' for 'Unsubscribe' and 'Preferences' for newsgroups [linux]

RESOLVED FIXED in Thunderbird 13.0

Status

Thunderbird
Toolbars and Tabs
--
minor
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Karsten Düsterloh, Assigned: aceman)

Tracking

Thunderbird 13.0
x86
Linux
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Shredder 3.0.2pre, Linux 64 bit debug build.

steps to reproduce:
- select newsgroup and make sure it has the focus 
- hit alt-e to open the Edit menu
- hit n to open Preferences

expected result:
Preferences dialog opens

actual result:
'Unsubscribe' menuitem is selected, you need hit n again to select the Prefences entry and hit return to open the Preferences dialog

possible solution:
switch Preferences accesskey to e again?
Severity: normal → minor
Summary: Double accesskey 'n' for 'Unsubscribe' and 'Preferences' for newsgroups → Double accesskey 'n' for 'Unsubscribe' and 'Preferences' for newsgroups [linux]
(Assignee)

Comment 1

6 years ago
Or change the access key of the less common Unsubscribe item?
(Assignee)

Comment 2

6 years ago
I am able to change accesskeys, I just need a UI decision here.
Keywords: uiwanted
(Assignee)

Updated

6 years ago
Assignee: nobody → acelists
(Assignee)

Comment 3

6 years ago
Ian Neal, is this relevant for Seamonkey too? It also uses "n" for Unsubscribe but I do not know what other menu items are there and if it clashes with anything.

My suggestion for Thunderbird is to change unsubscribeNewsgroupCmd.accesskey to 'b' as that is not yet used in the Edit menu.
I think it is better to change accesskey for the Unsubscribe command instead of Preferences. Preferences is always there and probably more known so keeping it unchanged is higher gain.

Comment 4

6 years ago
(In reply to :aceman from comment #3)
> Ian Neal, is this relevant for Seamonkey too? It also uses "n" for
> Unsubscribe but I do not know what other menu items are there and if it
> clashes with anything.
> 
> My suggestion for Thunderbird is to change unsubscribeNewsgroupCmd.accesskey
> to 'b' as that is not yet used in the Edit menu.
> I think it is better to change accesskey for the Unsubscribe command instead
> of Preferences. Preferences is always there and probably more known so
> keeping it unchanged is higher gain.

e is used for Preferences on SM. SM uses a different preferences dialog and nothing on any of the pref panes that is opened uses "e" as an accesskey, so I'm not sure if SM is affected. Karsten might know though.
(Assignee)

Comment 5

6 years ago
This is talking only about Edit menu. If your Preferences menu item does not use "n" then you are not affected and I will not touch SM. Thanks.
(Assignee)

Comment 6

6 years ago
Created attachment 592820 [details] [diff] [review]
patch

Change accesskey for Unsubscribe to 'b'. Reasoning in comment 3.
Attachment #592820 - Flags: ui-review?(bwinton)
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
Comment on attachment 592820 [details] [diff] [review]
patch

Seems reasonable, and reasonably well thought-out.

ui-r=me, and since I'm here, r=me, too.

Thanks,
Blake.
Attachment #592820 - Flags: ui-review?(bwinton)
Attachment #592820 - Flags: ui-review+
Attachment #592820 - Flags: review+
(Assignee)

Comment 8

5 years ago
Thanks!
Keywords: uiwanted → checkin-needed
Attachment #592820 - Attachment is patch: true
Checked in: http://hg.mozilla.org/comm-central/rev/37481eaa6c69
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 13.0
You need to log in before you can comment on or make changes to this bug.