query.cgi's PrefillForm should not be using a predetermined list

RESOLVED FIXED in Bugzilla 4.2

Status

()

enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: mkanat, Assigned: mkanat)

Tracking

Bugzilla 4.2
Dependency tree / graph

Details

(Whiteboard: [fixed by blocker])

Assignee

Description

9 years ago
There are a lot of bugs around (and that I've noticed) involving the fact that some field or another is not properly pre-filled on query.cgi. I think most of that is because PrefillForm has a hardcoded list when it doesn't need to have one. Maybe old versions of Template Toolkit had trouble when those variables weren't defined, but it's definitely not true now.

We should basically just be copying the cgi parameters entirely into the query defaults.
Assignee

Updated

9 years ago
Version: 3.5.3 → 3.7
Assignee

Updated

9 years ago
Target Milestone: Bugzilla 4.0 → Bugzilla 5.0
Assignee

Updated

9 years ago
Duplicate of this bug: 599953

Comment 2

9 years ago
Well, this is not an enhancement, but a bug, see the dupe.
Severity: enhancement → normal
Target Milestone: Bugzilla 5.0 → Bugzilla 3.6

Updated

9 years ago
Severity: normal → enhancement
Target Milestone: Bugzilla 3.6 → Bugzilla 5.0
Assignee

Updated

8 years ago
Depends on: 647649
Whiteboard: [blocker will fix]
Assignee

Updated

8 years ago
Assignee: query-and-buglist → mkanat
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [blocker will fix] → [fixed by blocker]
Target Milestone: Bugzilla 5.0 → Bugzilla 4.2
You need to log in before you can comment on or make changes to this bug.