View -> Folders does not switch to Unread, Favorite or Recent, only to Smart and All

RESOLVED FIXED

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Jordi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug # 505465])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

When selecting View -> Folders, if I choose Unread, Favorite or Recent, they all revert back to All.  Only Smart and All seem to be valid selections.

The same happens using the little arrows in the Folder pane, they only go to All Folders and Smart Folders.

Reproducible: Always

Steps to Reproduce:
1. Select View -> Folders -> Smart
2. The Smart Folders are shown in the Folder pane.  That's ok.
3. Select View -> Folders -> Favorite
4. The Folder pane changes to "All Folders"
Actual Results:  
Choosing Favorite, Unread or Recent goes to All Folders

Expected Results:  
The selected type of folder should appear in the Folder pane

Technically this is a minor loss of function, but for people like me who have been using Thunderbird for a while and are using more than 50 folders, the Favorite feature is very important.
Can you reproduce this in Safe Mode (http://kb.mozillazine.org/Safe_Mode)? Also, do you see any error messages in the Error Console (Tools -> Error Console)?
(Reporter)

Comment 2

8 years ago
Yes, it happens in Safe Mode.

Yes, I see an error in the Error Console (I selected view Favorite):
generator favorite failed with exception: TypeError: acct.incomingServer is null

Comment 3

8 years ago
Ah, you might try a 3.02 pre build and see if it fixes it for you - http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
(Reporter)

Comment 4

8 years ago
Interesting, David, you are responding to this bug and to the topic I posted in GetSatisfaction.com. Two different issues, but with a similar error message in the Error Console related to acct.incomingServer being null. You might be correct.

I've started to install the pre build but it says it's going to install Shredder, not Thunderbird, so I've canceled it. I have almost 9 Gb of email folders. How safe a pre build is? I don't mind waiting two weeks for its release.

Comment 5

8 years ago
Ah, you're the same person. That makes sense, since the underlying issue would cause both problems. 

The pre build is relatively safe. It is basically 3.01 + a handful of fixes. The fix for this bug basically cleans up your prefs.js file a bit, so if you can't back up your whole 9GB profile, just backing up your prefs.js file and trying 3.02 pre is an alternative. But we really recommend in general that your backup your profile for lots of other reasons. In any case, once 3.02pre does its cleanup on first run, you can go back to 3.01, and wait for 3.02 to come out officially.
(Reporter)

Comment 6

8 years ago
Ok, I'll try it over the weekend.

Comment 7

8 years ago
Thx, Jordi, please let us know how it goes.
(Reporter)

Comment 8

8 years ago
Yes, 3.02pre has fixed this issue and the Move/Copy as well.
You guys rock! You fix the problems before they get reported :-)
Thanks for everything.

Comment 9

8 years ago
this was fixed by the patch in bug 505465, then. Thx very much for testing this, Jordi!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug # 505465]
You need to log in before you can comment on or make changes to this bug.