WebGL Memory leak on texture update (NVIDIA HW and MESA SW)

RESOLVED DUPLICATE of bug 572018

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 572018
8 years ago
8 years ago

People

(Reporter: Hans Schmucker, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100211 Minefield/3.7a1pre ( LIKE Firefox/3.5 )
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100211

When a texture gets updates a lot of memory is leaked and not reclaimed until Firefox closes. This happens on both: Emulated software GL and hardware accelerated NVIDIA GL.
There are apparently two separate problems here:
1. deleteTexture is apparently not called by the webgl texture object destructor. Without explicit calling, hundreds of megabytes are wasted per second.
2. Even with the deleteTexture call, some (much less, but a few hundred megs are still piling up fairly quickly) memory is not freed... could be a buffer for the GL texture, not sure though.

This can be observed pretty well on the given url, but it also happens on the official Khronos texturing sample (if you reload it a couple of times)

Reproducible: Always

Steps to Reproduce:
1. Open the task manager
2. Open the link
3. Click play and wait a few seconds for the buffering to finish
Actual Results:  
Memory usage rises sharply as soon as the video starts playing.

Expected Results:  
Memory usage should increase slightly, then stay at that level.
(Reporter)

Updated

8 years ago
Hardware: x86 → x86_64
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Summary: Memory leak on texture update (NVIDIA HW and MESA SW) → WebGL Memory leak on texture update (NVIDIA HW and MESA SW)

Comment 1

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100409 Minefield/3.7a5pre

I have noticed a similar memory issue with the Learning WebGL lessons ( http://learningwebgl.com/blog/?page_id=1217 ) that I have been going through. If I am to leave it on one of the lesson examples ( http://learningwebgl.com/lessons/lesson03/index.html ) and just watch the memory consumption from the firefox process it continually increases. Refreshing the page makes the issue more prominent. Eventually the process will consume up to 1GB of memory. Upon further refreshes of the page will make the WebGL component unavailable from the script.
Can you please retry now? Tons of changes have recently happened in this area, so whatever the culprit code was, there's a big chance that it got replaced by something else... thanks!
This sounds like bug 572018
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572018
You need to log in before you can comment on or make changes to this bug.