Unix chatzilla.jst expects jars but chatzilla.xpi contains flat files

VERIFIED FIXED

Status

Other Applications
ChatZilla
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Samir Gehani, Assigned: dprice (gone))

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
With rev 1.5 of mozilla/xpinstall/packager/unix/chatzilla.jst the install script
expects chatzilla.jar to be present in chatzilla.xpi.  However, a jar isn't
built for chatzilla so installation (and chrome registration) fails.  Here's a
cample from my install.log (it's OK to use a unix chatzilla.xpi on windows since
it's all js, css, xul, and other xp files and used to work fine before):

-------------------------------------------------------------------------------
ftp://sweetlou/products/client/6.0x/unix/linux/2.2/x86/2000-09-28-10-MN6/mozilla-xpi/chatzilla.xpi
 --  09/28/2000 17:16:42
-------------------------------------------------------------------------------

     Chatzilla v0.5
     --------------

     ** initInstall: 0
     ** ERROR (-225): Installing: C:\Program Files\Netscape\Netscape
6\chrome\chatzilla.jar
     ** ERROR (-214): Register Package: C:\Program Files\Netscape\Netscape
6\chrome\chatzilla.jar
     ** ERROR (-214): Register Skin: C:\Program Files\Netscape\Netscape
6\chrome\chatzilla.jar
     ** ERROR (-214): Register Locale: C:\Program Files\Netscape\Netscape
6\chrome\chatzilla.jar
     [1/1]	Replacing: C:\Program Files\Netscape\Netscape 6\components\chatzilla-service.js

     Install completed successfully
     Finished Installation  09/28/2000 17:16:43


The build system should be fixed to deliver jars for chatzilla.
(Reporter)

Updated

18 years ago
Keywords: regression
(Reporter)

Comment 1

18 years ago
Does this need to be assigned/checked in by a mozilla.organ since chatzilla 
doesn't ship with Netscape 6 and so a Netscape engineer will probably not be 
focusing on this?  If so, does anyone have a suggestion as to who should fix 
this.  
(Assignee)

Comment 2

18 years ago
I believe this is happening because chatzilla isn't being built by default.
Chatzilla needs to be added to MOZ_EXTENSIONS_DEFAULT in configure.in  Who do I
talk to about getting this set?

Comment 3

18 years ago
Here's a silly question, why does the installation script expect a .jar file
when there isn't one?  If you build with chatzilla & w/o jars enabled, does the
installer exhibit the same behavior?

Samir, build using --with-extensions=default,irc to get around the problem.

On a side-note, I thought the reason chatzilla wasn't enabled by default was
because Netscape didn't want chatzilla in their builds.  If we added it by
default, all of the automation scripts would need to be changed to exclude
chatzilla.
(Reporter)

Comment 4

18 years ago
cls, this is strictly mozilla I'm talking about.  The chatzilla.xpi still gets
delivered so mozilla release builds include chatzilla however the zippy doesn't
install correctly.  I'm not worried about this problem in my builds.  I'd like
to see this fixed so that mozilla release builds produce stuff that works.  It
regressed when the jar packaging stuff landed.  This is a plea to undo the
regression.

Comment 5

18 years ago
I'm not seeing the problem here.  If you want to create a chatzilla.xpi, then
you need to make sure that you build with chatzilla.  If mozilla release builds
want to contain chatzilla, then they should run configure with the appropriate
options.  However, the script that creates the xpis needs to check to see if
we've actually built chatzilla before trying to create a chatzilla.xpi since
chatzilla is an optional component.

No, that is NOT the problem. The problem is that the chatzilla install script 
was changed to register chrome in a jar, but the chatzilla build--when enabled 
at all--does not put the chrome jar into the install archive.

The culprit appears to be that mozilla/xpinstall/packager/packages-unix was not 
updated when the build changed. The line
    bin/chrome/chatzilla/*
should be
    bin/chrome/chatzilla.jar
(Assignee)

Comment 7

18 years ago
a=dveditz SR=sfraser,dveditz
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
*MASS SPAM*

Changing QA contact on all open or unverified ChatZilla bugs to me, David
Krause, as I am now the QA contact for this component.
QA Contact: rginda → David

Comment 9

18 years ago
Verified fixed linux cvs build 2000101701.
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.