Line breaks broken in in ALT and TITLE text

RESOLVED DUPLICATE of bug 358452

Status

()

RESOLVED DUPLICATE of bug 358452
9 years ago
9 years ago

People

(Reporter: mikh2161, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091222 Firefox/3.5.6 Orca/1.2 build 6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Firefox doesn't seem to support line breaks in ALT and TITLE attributes.

Internet Explorer supports HTML character entities, including newline and carriage return (
 or 
). An alternative would be to use JavaScript escape sequences (\n or \r).

Reproducible: Always

Steps to Reproduce:
Example HTML code:

<p title="one&#xD;word&#xD;per&#xD;line">This is a sentence.</p>


Expected Results:  
The tooltip should render the text across four lines, with one word on each line.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358452
You need to log in before you can comment on or make changes to this bug.