Closed Bug 545991 Opened 11 years ago Closed 8 years ago

Stop and Reload combine only when reload is placed before stop

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: divjot94, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1) Gecko/20100208 Firefox 3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1) Gecko/20100208 Firefox 3.6

In Firefox 3.7 Alpha 1 Dev Preview , although stop and reload buttons are combined , but when we try to "Customize..." navigation bar , we are able to see the buttons separately. Further if we place reload after stop , then both are visible even after closing customize dialog(just like previous versions)



Reproducible: Always

Steps to Reproduce:
1.Right click on navigation bar
2.Click customize
3.Place reload next to stop
4.Close customize dialog by clicking done

Actual Results:  
Reload and Stop are visible separately after clicking "done" and are not combined

Expected Results:  
Reload and Stop should be combined and further should be visible as a single button when customizing navigation bar
Component: Build Config → Toolbars
QA Contact: build.config → toolbars
You can of course see both buttons again because that is a feature for all that people who want 2 buttons.
Are you sure that there is nothing between the 2 buttons like a separator ?
ah, and that they only merge if reload is placed before stop is wanted
https://bugzilla.mozilla.org/show_bug.cgi?id=343396#c103

marking this bug invalid
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
If the two buttons are next to each other, regardless of the order, we should be combining them.

It's not clear to users why we only combine in one direction but not in the other.
Status: RESOLVED → REOPENED
Ever confirmed: true
Hardware: x86 → All
Resolution: INVALID → ---
Whiteboard: [Australis:M?]
Version: unspecified → Trunk
The code for the combined stop/reload can be found here, http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#4148

It already handles one of the directions, it shouldn't be too hard to make it handle the other direction.
Status: REOPENED → NEW
Whiteboard: [Australis:M?] → [good first bug][mentor=jaws][lang=js][Australis:M?]
Jared:

Weren't we planning on binding those two buttons so that they couldn't be broken up, like the zoom and back and forward buttons?

-Mike
Flags: needinfo?(jaws)
Yeah, you're right. Thanks for the correction.
Flags: needinfo?(jaws)
(In reply to Mike Conley (:mconley) from comment #5)
> Jared:
> 
> Weren't we planning on binding those two buttons so that they couldn't be
> broken up, like the zoom and back and forward buttons?
> 
> -Mike

Please file a new bug for that.
No longer blocks: australis-cust
Status: NEW → RESOLVED
Closed: 11 years ago8 years ago
Resolution: --- → WONTFIX
Whiteboard: [good first bug][mentor=jaws][lang=js][Australis:M?]
You need to log in before you can comment on or make changes to this bug.