Crashes at nsGenericElement::GetNodeType when clicking on the above url

VERIFIED WORKSFORME

Status

()

P1
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: naving, Assigned: buster)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
One of my mails has the link and when I click on the link in 
the message window the crash occurs (Has occured 4 times).
 
Incident ID: 18224320

Here is the stack trace

  
  nsGenericElement::GetNodeType() 
                                                   
  nsHTMLFormElement::GetNodeType() 
                                              
     
  nsBrowserContentHandler::HandleContent() 
                                              
     
  nsURILoader::DispatchContent() 
                                              
     
  nsDocumentOpenInfo::DispatchContent() 
                                              
     
  nsDocumentOpenInfo::OnStartRequest() 
                                              
     
  nsMultiMixedConv::SendStart() 
                                              
     
  nsMultiMixedConv::OnDataAvailable() 
                                              
     
  nsDocumentOpenInfo::OnDataAvailable() 
                                              
     
  nsHTTPFinalListener::OnDataAvailable() 
                                              
     
  InterceptStreamListener::OnDataAvailable() 
                                              
     
  nsHTTPChunkConv::OnDataAvailable() 
                                              
     
  nsHTTPServerListener::OnDataAvailable() 
                                              
     
  nsOnDataAvailableEvent::HandleEvent() 
                                              
     
  nsStreamListenerEvent::HandlePLEvent() 
                                              
     
  PL_HandleEvent() 
                                              
     
  PL_ProcessPendingEvents() 
                                              
     
  nsEventQueueImpl::ProcessPendingEvents() 
                                              
     
  nsEventQueueImpl::ProcessPendingEvents() 
                                              
     
  event_processor_callback() 
                                              
     
  our_gdk_io_invoke() 
                                              
     
  libglib-1.2.so.0 + 0xe52a (0x4088952a) 
                                              
     
  libglib-1.2.so.0 + 0xfbe6 (0x4088abe6) 
                                              
     
  libglib-1.2.so.0 + 0x101a1 (0x4088b1a1) 
                                              
     
  libglib-1.2.so.0 + 0x10254 (0x4088b254) 
                                              
     
  nsAppShell::DispatchNativeEvent() 
                                              
     
  nsXULWindow::CreateNewContentWindow() 
                                              
     
  nsXULWindow::GetNewWindow() 
                                              
     
  nsContentTreeOwner::GetNewWindow() 
                                              
     
  GlobalWindowImpl::OpenInternal() 
                                              
     
  GlobalWindowImpl::Open() 
                                              
     
  nsBrowserContentHandler::HandleContent() 
                                              
     
  nsURILoader::DispatchContent() 
                                              
     
  nsDocumentOpenInfo::DispatchContent() 
                                              
     
  nsDocumentOpenInfo::OnStartRequest() 
                                              
     
  nsMultiMixedConv::SendStart() 
                                              
     
  nsMultiMixedConv::OnDataAvailable() 
                                              
     
  nsDocumentOpenInfo::OnDataAvailable() 
                                              
     
  nsHTTPFinalListener::OnDataAvailable() 
                                              
     
  InterceptStreamListener::OnDataAvailable() 
                                              
     
  nsHTTPChunkConv::OnDataAvailable() 
                                              
     
  nsHTTPServerListener::OnDataAvailable() 
                                              
     
  nsOnDataAvailableEvent::HandleEvent() 
                                              
     
  nsStreamListenerEvent::HandlePLEvent() 
                                              
     
  PL_HandleEvent() 
                                              
     
  PL_ProcessPendingEvents() 
                                              
     
  nsEventQueueImpl::ProcessPendingEvents() 
                                              
     
  event_processor_callback() 
                                              
     
  our_gdk_io_invoke() 
                                              
     
  libglib-1.2.so.0 + 0xe52a (0x4088952a) 
                                              
     
  libglib-1.2.so.0 + 0xfbe6 (0x4088abe6) 
                                              
     
  libglib-1.2.so.0 + 0x101a1 (0x4088b1a1) 
                                              
     
  libglib-1.2.so.0 + 0x10341 (0x4088b341) 
                                              
     
  libgtk-1.2.so.0 + 0x8c209 (0x407b5209) 
                                              
     
  nsAppShell::Run() 
                                              
     
  nsAppShellService::Run() 
                                              
     
  main1() 
                                              
     
  main() 
                                              
     
  libc.so.6 + 0x181eb (0x402581eb)

Comment 1

18 years ago
WFM in NT in 200100212

adding crash keyword and cc:ing Buster...
(Assignee)

Comment 2

18 years ago
WFM on Windows.
cc-ing some linux folks.  Can anybody reproduce this?
Status: NEW → ASSIGNED
Priority: P3 → P1

Comment 3

18 years ago
I dont get a crash on my linux box. WFM RedHat Linux 6.2

Comment 4

18 years ago
I don't see the crash with the linux beta candidate.  What build were you using
when you saw this crash?
(Reporter)

Comment 5

18 years ago
Forwarding the e-mail that causes the crash.

Comment 6

18 years ago
I'm not seeing this either. Navin, perhaps you could save out the mail that
contains the link and causes the crash so we can add it to our mailboxes for
testing?
(Reporter)

Comment 7

18 years ago
What builds are you using to test ?
(Reporter)

Comment 8

18 years ago
Created attachment 16184 [details]
Created an attachment of the message that causes the crash.
(Assignee)

Comment 9

18 years ago
has anyone been able to reproduce this crash?
cc-ing some mail folks, since this linux-only crash reportedly only happens when
reading the attached mailnote.  any clues?
Assignee: clayton → buster
Status: ASSIGNED → NEW

Comment 10

18 years ago
I cannot reproduce this problem on the trunk with a current Linux build. Here is
what I tried:

1. Save attached message as ~/.mozilla/waterson/Mail/Mail/Local\ Folders/Test
2. Run mozilla -mail
3. Open "Test" folder inside "Local Mail"
4. Click on message
5. Click link in message

WORKSFORME.
(Reporter)

Comment 11

18 years ago
Worksforme using today's linux build 2000100610
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
Marking works for me in the Oct 25th builds.
Keywords: vtrunk

Comment 13

18 years ago
unable to reproduce with trunk linux build 122610. 
Status: RESOLVED → VERIFIED
Keywords: vtrunk
You need to log in before you can comment on or make changes to this bug.