Unusual behaviour of alarm dialog, Google Calendar SMS service still too hard to set up.

RESOLVED DUPLICATE of bug 432675

Status

Calendar
Provider: GData
RESOLVED DUPLICATE of bug 432675
8 years ago
8 years ago

People

(Reporter: hch, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: 0.6b1 (Sunbird 1.0b1)

a. Unusual dialog behaviour
a1. UI bugs: the cell phone icon in the combo "Choose a Reminder Action" is too high, which leads to unnecessary dynamic dialog rearrangement ("jumping"). And if I'm not mistaken, the "relative" controls are a bit higher than remaining combos due to the tall numeric spinner. It's a matter of personal taste; I consider uniformly sized controls nicer.

a2. The selected reminder is direcly edited by "quite distant" (and even separated by the two buttons) controls, and without any confirmation. There's no implicit way to revert the last change, one has to remember the previous state. And the "Add" function creates a new item with (default) "values coming from nowhere"; one has to take this "template" and modify it later. Such handling is the exact opposite of my habbit I gained during decades spent among computers.

a3. I'm not convinced this dialog should be resizable at all; it should have a minimum at least. To be honest, I don't know whether this can be easilly accomplished in the plugin environment. 

b. SMS service
There's no way to specify default reminder for the provider, or at least I haven't found any. I insist in SMS, and really like predefined default with easily customizable multiple reminders found in web version of GC. Therefore I find very cumbersome to get them instantiated, even only for events worth such effort. The "Custom" option is the last one (compared to topped "No reminder"), and the fixed default does not suit me most of time.

I know this feature was talked about several times, and pronounced "fixed" (bug 353492), but it prevents me from using this client-side calendar solution, and maybe I'm not the only unsatisfied one. 


Reproducible: Always
Please file one bug per issue in the future, its hard to track everything in one bug.

> a. Unusual dialog behaviour
> a1. UI bugs: the cell phone icon in the combo "Choose a Reminder Action" is too
> high, which leads to unnecessary dynamic dialog rearrangement ("jumping"). And
> if I'm not mistaken, the "relative" controls are a bit higher than remaining
> combos due to the tall numeric spinner. It's a matter of personal taste; I
> consider uniformly sized controls nicer.
I agree, this is worth a separate bug, please file it (unless it already exists).


> a2. The selected reminder is direcly edited by "quite distant" (and even
> separated by the two buttons) controls, and without any confirmation. There's
> no implicit way to revert the last change, one has to remember the previous
> state. And the "Add" function creates a new item with (default) "values coming
> from nowhere"; one has to take this "template" and modify it later. Such
> handling is the exact opposite of my habbit I gained during decades spent among
> computers.
I believe the value comes from the current default alarm settings in the preferences. See bug 432675 for revising the default prefs, this may solve this issue.

> 
> a3. I'm not convinced this dialog should be resizable at all; it should have a
> minimum at least. To be honest, I don't know whether this can be easilly
> accomplished in the plugin environment. 
Setting minimum widths on dialogs is unfortunately not possible due to a mozilla bug. We might be able to make the dialog non-resizable though. I'll have to think about the implications, please file a separate bug for this too (unless it already exists).

> b. SMS service
> There's no way to specify default reminder for the provider, or at least I
See bug 432675 for changing the alarms prefs pane. There is no way to use the default reminder from Google Calendar right now because there is no easy way to read out this pref from Google, so all I could do is add a checkbox "Use Google Defaults". Some users might get confused why there are two sets of default prefs.

Marking this bug a duplicate of bug 432675 for now, please search for and/or file bugs as separate issues as mentioned above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432675
You need to log in before you can comment on or make changes to this bug.