installer aborts silently

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
P3
normal
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: John Bandhauer, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
With both the NS Commercial and mozilla installer builds I get to the "Preparing 
Install, please wait" dialog and then the installer just exits without warning. 
It has cleaned up its temporary files and its temp directory. The target 
location gets empty Plugins and Uninstall directories. The only file written is 
the install_wizard.log contianing:

     ** create folder: C:\Program Files\Netscape\Netscape 6
     ** create folder: C:\Program Files\Netscape\Netscape 6\Plugins
     ** create folder: C:\Program Files\Netscape\Netscape 6\Uninstall

I see the same thing whether I use the all-in-one sea or the xpi installer.

I just verified that this is on the branch build:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-09-28-09-MN6/sea
/N6Setup.exe

My machine is a Dell Inspiron 7500 running NT 4 SP5

This is my main development machine with a lot of software and various old 
mozilla and netscape builds. I tried to root out any old registry files and that 
sort of thing in case it mattered. No luck.

I have 380 meg free on the C drive after it has unpacked the xpi files. It fails 
the same way if I target the D drive which has over a gig free. I have 256 meg 
of memory. I tried running the installer (release build of course) under the 
debugger and got nothing interesting - the app exists with a zero result - no 
error code.

Anyone else report this kind of problem? any known workarounds? Any ideas on how 
to debug it?
(Reporter)

Comment 1

17 years ago
I forgot to mention... I don't often install daily builds. I did try to do so 
last week to do a memory test and it failed as explained above. I neglected to 
file a bug right then and forgot about the issue. So, this may not be a new 
problem. There may be something very specific about my machine that keeps this 
from working. I dunno.
(Assignee)

Comment 2

17 years ago
I will have to take a look at your system.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

17 years ago
I just did a debug build of the mozilla trunk installer and, of course, it 
worked fine. I'll build a branch and commercial debug version and see what 
happens.
(Reporter)

Comment 4

17 years ago
My debug build of the full Commercial branch installer works just fine - both 
the setup.exe and the sea version. It remains a mystery why this machine does 
not like the release versions.
(Reporter)

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
I'm resolving this as WORKSFORME. I can no longer reproduce this. I've been 
successfully installing nightly builds for the past few weeks on the machine 
that was unable to do this before. I don't know what changed.

Comment 6

17 years ago
installer build 20010129
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.