Closed Bug 546373 Opened 15 years ago Closed 14 years ago

Crashed caused by OOM related to OOPP

Categories

(Core :: IPC, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: robarnold, Unassigned)

References

Details

(Keywords: crash)

Attachments

(6 files)

I had a window open with two tabs, one of which had been viewing a PDF but I had clicked "back" on so it was not showing (also its tab was not the active one). I clicked the close button on the window and the entire browser locked, went to using a full core and started increasing in memory usage - about 100 MB/min. I tried the usual technique of killing the plugin process but that only delayed the memory increase - it resumed and eventually killed the process, never responding to my mouse click. During this time I noticed a steady and rapid rate of messages: WM_PAINT and the nsAppShell message perfectly interleaved being dispatched. I'll attach a few stack traces and hopefully someone more knowledgeable about OOPP will have some insight.
Attached file Sample Trace 1
Attached file Sample Trace 2
Attached file Sample Trace 3
Attached file Sample Trace 4
Attachment #427060 - Attachment mime type: application/octet-stream → text/plain
Attachment #427059 - Attachment mime type: application/octet-stream → text/plain
Attached file Sample Trace 5
Blocks: OOPP
Hey Rob, what version/nightly was this? This looks like bug 543788.
(The final patch for bug 543788 just landed on m-c this morning.)
(In reply to comment #7)
> Hey Rob, what version/nightly was this? This looks like bug 543788.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100211 Minefield/3.7a2pre (.NET CLR 3.5.30729)
Rob, 
can you still reproduce this with trunk?
If not, please close WFM
Severity: normal → critical
Keywords: crash
I have not reproduced this since.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: