'Enable Global Search and Indexer' losing preference

RESOLVED DUPLICATE of bug 542953

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 542953
8 years ago
8 years ago

People

(Reporter: Trel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 Compatible SeaMonkey/1.1.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

Every once in a while, I will go to filter messages, and it will do a search instead.  When I look at preferences, the box fox 'Enable Global Search and Indexer' is still unchecked.  If I check it, say ok, and then go back in and un check it again, Thunderbird resumes correct functionality.

This has happened five times already.

Reproducible: Didn't try

Steps to Reproduce:
Not sure what happens to cause it, except that it never happens so long as thunderbird remains running.  It only happens after it's opened after being closed (but not every time).

Comment 1

8 years ago
Trel, I don't quite understand your "steps". Please list them as 
1.
2.
3....

Also, do you see anything in the error console?

bug 539638 also reports enable/disable issue
(Reporter)

Comment 2

8 years ago
I can't give 'step's since I don't know for sure what's causing it.

All I can say is, sometimes when I start Thunderbird and go to filter messages, I find that global search has re-enabled itself (though the checkbox still shows it as not enabled)
(Reporter)

Comment 3

8 years ago
Ok I can give steps to reproduce, but it's not 100%.

1. Uncheck the option to use the global search indexer.
2. Close program
3. Reopen program
4. Recieve mail on imap connection
5. type something in the search bar and hit enter

Expected results: list is filtered to show items with search phrase in subject line or sender
Actual results: it attempts to do a search

Correcting the behavior is done by going and re-enabling the global search indexer, saying ok, then going back in and unchecking it again.
It lasts the whole time the programs is open, but then goes away again once it's closed and re-opened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542953
You need to log in before you can comment on or make changes to this bug.