Weave overwrite actual status with old status

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: axel.braun, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-10-31])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6
Build Identifier: Firefox 3.6

I synced three installations with weave, spend some hours to verify and rearrange my bookmarks and synced again.
Now, using one other of the above installations, I used 'start over' to import and overwrite the current bookmarks with the ones synchronized in weave. For whatever reason, nothing happened.

Now, coming back to the machine were I did all the sorting work, I noticed that the cleaned status was gone, and instead overwritten with an aged status.
Despite the fact that I'm absolutely p**ed about the wasted time, is there a way to get my sorted stuff back?

I tread this as critical, as it is a data loss

Reproducible: Always
(Reporter)

Comment 1

9 years ago
related to weave 1.01

Updated

9 years ago
Component: General → Needs Triage
QA Contact: general → needstriage
Almost certainly not, though there was an unrelated server problem which could have contributed.  You may have a timed backup from Firefox that has the desired bookmark structure?
(Reporter)

Comment 3

9 years ago
I saw that there is a backup of the bookmarks that allowed to recover the previous status.
I then told weave to overwrite the weave data with the current settings on this machine.
The sync did not report any issues.
This morning I took a different PC and tried to sync, which did not work.
I went to 'start over' -> replace everything with weave data
Everyhing was deleted, but nothing replaced!
after a restart of FF there was a small note that weave needed to be updated (was still 1.0 on this machine), after the update the sync worked.
So it may be realted to the server problem, but it leaves a unsecure feeling....

Updated

8 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
Axel, does this still happen with current builds?
Whiteboard: [closeme 2010-10-31]
This should be long since fixed, please file a new bug if this has regressed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.