caching CSS screwing up character coding and everything else.

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: tarahim, Assigned: ftang)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This page shows up as garbage.  It is written in Japanese with two gif images.  
Setting the character coding manually from View menu does not help.
M182000092812
(Reporter)

Comment 1

18 years ago
This only happens when cache is turned ON.  Might be a dupe.
I have not encountered this bug in recent builds since my cache has been set 
to Zero for quite some time.
Component: Style System → Networking: Cache
Summary: CSS screwing up character coding and everything else. → caching CSS screwing up character coding and everything else.

Comment 2

18 years ago
Reassigned to ftang for investigation.
Assignee: pierre → ftang
(Reporter)

Comment 3

18 years ago
The original URL has been changed and I can not see the bug any more in 
2000092920.  I will try if I can manage to make a test case.
(Reporter)

Comment 4

18 years ago
Here is another page that shows up as a garbage when cache is turned on which is 
less likely to change in a short term than the one I reported initially.
Mem cache was set at 1024, Disk cache at 4096.
Changed the URL for better test case.
(Reporter)

Comment 5

18 years ago
Here is another page that shows up as a garbage when cache is turned on which is 

less likely to change in a short term than the one I reported initially.

Mem cache was set at 1024, Disk cache at 4096.

Changed the URL for better test case.

Interestingly, when I DLed the source and changed all the relative hrefs to true 

URLs, and opened the file locally, it showed up fine.

(Reporter)

Comment 6

18 years ago
After some tests, I added Japanese codings to the default list from View|
Character codings|Customize|, and hit reload. Then Mozilla loaded the page 
correctly, and the bug disappeared afterwards.
http://www.gihyo.co.jp/css/
also gave a similar behavior.  Is this cache, css, or language support?
(Assignee)

Comment 7

18 years ago
I have no clue what the bug is. The description is very unclear. What is the
expected behavior, what is the actuall behavior.
Since the reporter said " the bug disappeared afterwards."

These css file have Shift JIS inside the comment but it does not lable as
Shift_JIS by @charset . Therefor, while we load this file by using ISO-8859-1,
it won't display correctly.
The author should put @charset to indicate this CSS is encoded in Shift_JIS

Mark this bug invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

18 years ago
The expected behavior even under iso-8859-1 interpretation should be that only the text part be incorrectly 
shown.
The actual behavior was gif image turned up as a raw code starting with GIF89 etc.
Is this a correct behavior when Shift_JIS charset is used without being labeled?
(Reporter)

Comment 9

18 years ago
I think now I understand this bug.  This is a cache-related bug, and all the 
wrongs involved background/inline gif images either showing up as GIF89a etc. 
(View defaulted to ISO-8859-1), or something else (switched to  UTF16-LE by 
Mozilla).
I even saw this happen in pages without CSS, such as http://www.npr.org.
I will query and see if I should file another bug report.
INVALID confirmed.

Comment 10

18 years ago
Verified invalid - reporter in agreement.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.