layout/generic/test/test_backspace_delete.xul fails on some computers with the HTML5 parser enabled

RESOLVED WORKSFORME

Status

()

Core
Editor
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
62268 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Right movement broken in "**HA!H5HI-", offset 5 - got 7, expected 5
62270 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Delete broken in "**HA!HI-", offset 5 - got 7, expected 5
62271 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Delete broken in "**HA!HI-", offset 5 - got "**HA!HI-", expected "**HA5HI-"
62273 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Right movement broken in "**HA!HI-", offset 8 - got 9, expected 8
62275 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Delete broken in "**HA!HI", offset 8 - got 9, expected 8
62276 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Delete broken in "**HA!HI", offset 8 - got "**HA!HI", expected "**HA5H-"
62278 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | Right movement broken in "**HA!HI", offset 9 - got 10, expected 9
62279 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/generic/test/test_backspace_delete.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIController.doCommand]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
(Reporter)

Comment 1

8 years ago
The same failure happens on Mac.
Summary: [HTML5] layout/generic/test/test_backspace_delete.xul fails → [HTML5][Editor] layout/generic/test/test_backspace_delete.xul fails
(Reporter)

Comment 2

8 years ago
I don't see this on the tryserver. I do see it on a fast Linux x86_64 box locally. My guesses are that the test is either timing-sensitive or that it depends on the installed fonts.
Component: HTML: Parser → Editor
Priority: P1 → --
QA Contact: parser → editor
Summary: [HTML5][Editor] layout/generic/test/test_backspace_delete.xul fails → layout/generic/test/test_backspace_delete.xul fails on some computers with the HTML5 parser enabled

Comment 3

8 years ago
Can you paste a full log of the tests, including the passed ones?  I don't see anything in the test relying on the installed fonts.  Although the text you pasted in comment 0 seems broken.
(Reporter)

Comment 4

8 years ago
Created attachment 431571 [details]
mochitest-plain.log, gzipped

Here's the log. gzipped to work around Bugzilla's file size limit.

Comment 5

8 years ago
Can you try replacing the characters with Latin characters (and maintaining the logic of the test) and seeing if the test still fails?
Created attachment 434056 [details]
mochitest log file for Fedora 12 unittest failures of test_backspace_delete.xul

This is happening consistently on our Fedora 12 talos/unittest staging test box.

Comment 7

8 years ago
(In reply to comment #6)
> Created an attachment (id=434056) [details]
> mochitest log file for Fedora 12 unittest failures of test_backspace_delete.xul
> 
> This is happening consistently on our Fedora 12 talos/unittest staging test
> box.

Do you mean that this fails all the time on that machine?  Any chance I can get access to the machine?
Ehsan - I filed a separate bug for the packaged unittest failure: bug 554363
Isn't this a dup of bug 474068?

Comment 10

8 years ago
Have you tried running this test without the HTML5 parser but with the same version of Pango?
Is this still a valid bug? any recurrences?

Comment 12

8 years ago
Does this happen on the new unit test on desktop machines?  Henri, can you still reproduce this?
(In reply to comment #11)
> Is this still a valid bug? any recurrences?

(In reply to comment #12)
> Does this happen on the new unit test on desktop machines?  Henri, can you
> still reproduce this?

Is this still a valid bug, or can we close this?

Comment 14

7 years ago
Let's call it WFM, unless Henri still sees it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 15

7 years ago
Maybe this was a duplicate of bug 474068?
You need to log in before you can comment on or make changes to this bug.