SIP button does not show with form helper when selecting a menulist

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Fennec 1.1
All
Windows Mobile 6 Professional

Details

(Whiteboard: mothballed)

(Reporter)

Description

9 years ago
Build id:
Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2.2pre) Gecko/20100217 Namoroka/3.6.2pre Fennec/1.0a4pre

Steps to Reproduce:
1. Go to www.mibbit.com/chat
2. Select the IRC channel list drop down box

Actual Results:
SIP button is not shown

Expected Results:
For a long menu box list, the feature that vingtetun implemented was to allow users to select entries via keyboard strokes. On the Omnia 2, I can't do such things and are relegated to panning the long list of IRC channel entries.
(In reply to comment #0)
> Build id:
> Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2.2pre) Gecko/20100217
> Namoroka/3.6.2pre Fennec/1.0a4pre
> 
> Steps to Reproduce:
> 1. Go to www.mibbit.com/chat
> 2. Select the IRC channel list drop down box
> 
> Actual Results:
> SIP button is not shown

What do you call SIP?

> 
> Expected Results:
> For a long menu box list, the feature that vingtetun implemented was to allow
> users to select entries via keyboard strokes. On the Omnia 2, I can't do such
> things and are relegated to panning the long list of IRC channel entries.

I guess you don't have any keyboard. hmmm - maybe we can add a kind of fake alhphabet on the list with only the letter that it used into the list (as first letter).
I'm not sure what to do when every letters is used thought
I don't think think we want to show the keyboard, this bug is really about big select boxes being hard to use.  I've seen a lot of touch UI's using a variation of what I think Vivian is suggesting, and I really like it.  Basically just list the alphabet a-z and jump to that point of the list (or the next letter if it doesn't exist).
It stays to found a nice way to display the alphabet since we will commonly face some unordered list.

Maybe clicking on a specific letter could hide the rows which are not starting with it?
This year we mothballed windows mobile development.  See:

  http://blog.pavlov.net/2010/03/22/stopping-development-for-windows-mobile/

Marking bugs in the windows mobile / windows ce bucket as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: mothballed
Component: Windows Mobile → General
QA Contact: mobile-windows → general
Hardware: ARM → All
You need to log in before you can comment on or make changes to this bug.