Startup Crash in [@ npwinext.dll@0x33c79 ] Bing Searchbar

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

This crash is currently ranked the #4 Windows crash on the trunk. All of the reports are startup crashes and the npwinext.dll seems to be associated with the MSN Toolbar from info I could find on the web example: - C:\Program Files\MSN Toolbar\Platform\4.0.0346.1\npwinext.dll

npwinext.dll  	npwinext.dll@0x33c79  	
npwinext.dll 	npwinext.dll@0x33de6 	
npwinext.dll 	npwinext.dll@0x4f982 	
npwinext.dll 	npwinext.dll@0x50639 	
xul.dll 	mozilla::plugins::PluginInstanceChild::AnswerNPP_SetWindow 	dom/plugins/PluginInstanceChild.cpp:521
xul.dll 	mozilla::plugins::PPluginInstanceChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:1029
xul.dll 	mozilla::plugins::PPluginModuleChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:390
xul.dll 	mozilla::ipc::RPCChannel::DispatchIncall ipc/glue/RPCChannel.cpp:429
xul.dll 	mozilla::ipc::RPCChannel::Incall ipc/glue/RPCChannel.cpp:414
xul.dll 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne ipc/glue/RPCChannel.cpp:346
xul.dll 	MessageLoop::RunTask ipc/chromium/src/base/message_loop.cc:331
xul.dll 	MessageLoop::DeferOrRunPendingTask ipc/chromium/src/base/message_loop.cc:339
xul.dll 	MessageLoop::DoWork ipc/chromium/src/base/message_loop.cc:439
xul.dll 	base::MessagePumpForUI::DoRunLoop ipc/chromium/src/base/message_pump_win.cc:209
xul.dll 	base::MessagePumpWin::RunWithDispatcher ipc/chromium/src/base/message_pump_win.cc:52
xul.dll 	base::MessagePumpWin::Run ipc/chromium/src/base/message_pump_win.h:78
xul.dll 	MessageLoop::RunInternal ipc/chromium/src/base/message_loop.cc:211
xul.dll 	MessageLoop::RunHandler 	
xul.dll 	MessageLoop::Run ipc/chromium/src/base/message_loop.cc:168
xul.dll 	base::Thread::ThreadMain ipc/chromium/src/base/thread.cc:165
xul.dll 	`anonymous namespace'::ThreadFunc ipc/chromium/src/base/platform_thread_win.cc:26
kernel32.dll 	BaseThreadStart 	

Show/hide other threads

Updated

8 years ago
Summary: Startup Crash in [@ npwinext.dll@0x33c79 ] (MSN Toolbar?) → Startup Crash in [@ npwinext.dll@0x33c79 ] Bing Searchbar

Comment 2

8 years ago
We have some OOPP problems here, starting with an easy to reproduce version of the illusive CallSetFocus hang (bug 545239). Looking at this now.

Comment 3

8 years ago
(In reply to comment #2)
> We have some OOPP problems here, starting with an easy to reproduce version of
> the illusive CallSetFocus hang (bug 545239). Looking at this now.

OOPP focus hangs will be fixed by the patch in bug 545239.

The current rev I downloaded was 5.0.1363.0, and I haven't experienced any crashing yet. Will keep looking, but maybe they've fixed this in the newer release.

Comment 4

8 years ago
this particular signature "npwinext.dll@0x33c79" seems to exist in  3.7a3 3.7a2 3.6.3 and 3.5.9 although its much more frequent on the trunk

checking --- npwinext.dll@0x33c79 20100411-crashdata.csv
found in: 3.7a3 3.7a2 3.6.3 3.5.9
release total-crashes
              npwinext.dll@0x33c79 crashes
                         pct.
all     309235  167     0.000540042
3.7a3   1618    141     0.0871446
3.7a2   192     13      0.0677083
3.6.3   212615  8       3.76267e-05
3.5.9   28010   5       0.000178508

Comment 5

8 years ago
It looks like there are no urls for this signature.

  13 "blank"
 154 \N

with the OOPP crashes do URLs still get passed along?

Comment 6

5 years ago
all crashes of the last 2 months have been version 3.x
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.