Closed Bug 546746 Opened 12 years ago Closed 6 years ago

Remove cookie prompting UI

Categories

(Core :: Networking: Cookies, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 606655

People

(Reporter: dwitte, Unassigned)

References

Details

This is a feature sorely in need of reimplementing, and (mostly by definition, due to its unusability) isn't used by many people. Which makes it a perfect candidate to be an extension.

In order to make this happen, we first need to rejigger the backend a little such that it easily supports this kind of extension. Then we can ditch the backend and frontend code that implements it.

For bonus points, I may actually write the extension, but any help here would be appreciated. (Taking the current code verbatim would be acceptable.)
Blocks: 548451
See bug 551179 relating to this prompting that I just posted. 

I would like to keep the feature, as its the only way to stop random shopping/marketing sites tracking you, while allowing functional sites to use cookies to work. 

I agree with you that one reason people don't use it much is that its UI isn't very helpful.
Reassigning to nobody. If anyone wants to work on this, feel free!
Assignee: dwitte → nobody
I agree w #1, we need the existing functionality, but with a 
UI you can actually use.
 see: 
bug 420155 Large number of cookies come in and the active dialog does not always have the focus 
bug 420512 	The Cookie LEARN option cannot be stopped at once and begs many times until website stops setting cookies (Show Votes)
bug 434971 
and many more
Would sending an observer notification with an nsISupportsBoolean be enough as an API to rip out the cookie dialog [1]? The subject could be the window, the data could be formatted and hold information about the cookie?

https://hg.mozilla.org/mozilla-central/file/6c1c7e45c902/extensions/cookie/nsCookiePermission.cpp#l321
Sounds reasonable to me.
Flags: firefox-backlog?
This is not likely to be picked up by the Firefox team in the foreseeable future.
Flags: firefox-backlog? → firefox-backlog-
My request was due to Bug 633763 mentioning this as causing bugs unless removed, hence the tracking. And it's not just flipping a hidden pref, it's triggered by custom cookie settings in the privacy tab (see e.g. Bug 440973). Would you mind reconsidering the decision, please?
Flags: needinfo?(gavin.sharp)
I guess I misread bug 633763 - didn't know the UI was still active. We should just remove that, which is separate from this bug. I filed bug 1016077.
Flags: needinfo?(gavin.sharp)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606655
You need to log in before you can comment on or make changes to this bug.