Closed Bug 546777 Opened 15 years ago Closed 14 years ago

Shockwave Flash Crashes on YouTube and TalkShoe Flash Chat Rooms [@ NPSWF32.dll@0x2e655a]

Categories

(External Software Affecting Firefox Graveyard :: Flash (Adobe), defect)

x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aaron_2778, Unassigned)

References

()

Details

(Keywords: crash, flashplayer, Whiteboard: Flash 10,1,51,95)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre

I am Mozilla MineField and Mozilla Firefox 3.6.  It will allow me to watch a few videos then the Shockwave Flash will crash and I will have to Ctrl + Shift + Esc some times and some times all I have to do is just Refresh the browser.  I am using a clean install of a full OEM version of Windows 7 Professional.  I have the latest flash 10 plugin and its still doing it.  This issue also affects the TalkShoe site because the same thing happens on that when you access there Flash based Chat rooms except there it causes the whole browser to crash and close itself out and ask to send a Crash report through the Crash reporting tool to Mozilla.  If the Issue is on Mozilla's side please fix the issue but if it is on Adobes side please let us know so we can complain to the right company to get this issue fixed.

Reproducible: Sometimes

Steps to Reproduce:
1.Just go to YouTube and start watching videos in High Quality or access a TalkShoe Chatroom and just talk in it for awhile and it will crash.
2.For YouTube you have to watch a short Series of videos and even use the full screen mode.  Try backing up the video and that causes it to crash some times also
3.Some times rewatching the video from the beginning will cause it to freeze also
Actual Results:  
On YouTube the video box will change with a plugin picture that says Shockwave flash has crashed.  Some times freezes the browser.  On TalkShoe it will Close out the Browser and open up the crash reporting tool then run the tool.  Then I have to manually open up the browser again.

Expected Results:  
On youTube it Should not of Crashed.  And it should not of Crashed and on TalkShoe.  In other words it should work withought Error.  

I have the Summer Clouds them in MineField but it was crashing even before I added the Theme so I don't see how that wold be relevant.  These are the Crash reports I submitted.  Through the Crash Reporting Tool.  http://crash-stats.mozilla.com/report/index/04d622c3-7cd1-4e65-ad02-485022100211
http://crash-stats.mozilla.com/report/index/bp-1050b49b-7ee3-4df6-8dd6-719c02100211
http://crash-stats.mozilla.com/report/index/9eb5af9f-60f4-4c70-a909-fe8942100211
http://crash-stats.mozilla.com/report/index/a0896618-43ae-436e-99ef-a1a582100217
So, you are using flash 10.0 r45?
I am using flash 10.0 r45.
And you are crashing in the firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe%20Mode

In that case there is nothing we can do, it's the flash plugin that crashes.
You could try to remove the stored adobe flash settings under your user Account.
Hmm, what is our Adobe contact for such crashes ?
I am in regular mode when the latest version of Mozilla MineField and FireFox 3.6 Crashes..
(In reply to comment #1)
> So, you are using flash 10.0 r45?

I am using flash 10.0 r45.
(In reply to comment #3)
> And you are crashing in the firefox safemode ?
> http://support.mozilla.com/en-US/kb/Safe%20Mode
> 
> In that case there is nothing we can do, it's the flash plugin that crashes.
> You could try to remove the stored adobe flash settings under your user
> Account.
> Hmm, what is our Adobe contact for such crashes ?

I am in regular mode when the latest version of Mozilla MineField and FireFox
3.6 Crashes..
>I am in regular mode when the latest version of Mozilla MineField and FireFox
>3.6 Crashes..

I know and expected that you are in the normal mode. You should retest in the Firefox safemode


0  	NPSWF32.dll  	NPSWF32.dll@0x2e652a  	
1 	NPSWF32.dll 	NPSWF32.dll@0x2e212a 	
2 	NPSWF32.dll 	NPSWF32.dll@0x2e1498 	
3 	NPSWF32.dll 	NPSWF32.dll@0x63dc1 	
4 	NPSWF32.dll 	NPSWF32.dll@0x64002 	
5 	NPSWF32.dll 	NPSWF32.dll@0xada8a 	
6 		@0x2026b6f 	
7 	msacm32.drv 	msacm32.drv@0x148d 	
8 	winmm.dll 	waveMessage
I first tried in safe mode and disabled all plugins to see if that would work and the flash still crashes  And here is the report of that test.  

http://crash-stats.mozilla.com/report/index/bp-e42dcd40-e9c0-4cfb-91c4-20dfc2100225

http://crash-stats.mozilla.com/report/index/bp-5372e016-68b1-4d0a-b797-15c9b2100225

Now I am going to test in safe mode without disabling my add-ons.
Keywords: crash
I tried it again in safe mode withought disabling any of my add-ons and then tried to view a video and it crashed again.  It crashes on youtube and it crashes on Veoh video site as well.  Also all flash advertising banners crash.  Not only does YouTube crash now but some times it will only display the black video box and then when you go to refresh your browser to see if it will play you will get the Shockwave Crash thing or you get the black box and that is all you get.  Here is the crash report.  
http://crash-stats.mozilla.com/report/index/bp-7cca233e-8fac-4a47-9c0d-578892100225    It crashes on Yahoo as well...  Here is one video it will crash on before the 5 minute preview is up at http://www.veoh.com/browse/videos/category/entertainment/watch/v428834jBkhb9M8#watch%3Dv2116399ph45zzA
Hi Aaron,  

Could I asked you to try a few things.
1) Clear your Cache :)
2) Do a clean uninstall of the Flash Player
http://download.macromedia.com/pub/flashplayer/current/uninstall_flash_player.exe

   1. Click Start > Run.
   2. Type cmd in the Open box, and then press Enter.
   3. In the command window, type the following:

      uninstall_flash_player.exe /clean

3)Reinstall the player 
4) Reboot 

Does it still reproduce?
The latest crash reports are a Mozilla bug and not a flash one. 
The reporter is running a nightly with OOP

0  	mozcrt19.dll  	memmove  	 MEMCPY.ASM:188
1 	xul.dll 	nsTArray_base::ShiftData 	obj-firefox/xpcom/build/nsTArray.cpp:173
2 	xul.dll 	nsTArray<mozilla::plugins::BrowserStreamChild::PendingData>::RemoveElementsAt 	obj-firefox/dist/include/nsTArray.h:697
3 	xul.dll 	nsTArray<mozilla::plugins::BrowserStreamChild::PendingData>::RemoveElementAt 	obj-firefox/dist/include/nsTArray.h:702
4 	xul.dll 	mozilla::plugins::BrowserStreamChild::DeliverData 	dom/plugins/BrowserStreamChild.cpp:239
5 	xul.dll 	mozilla::plugins::BrowserStreamChild::RecvWrite 	dom/plugins/BrowserStreamChild.cpp:130
6 	xul.dll 	mozilla::plugins::PBrowserStreamChild::OnMessageReceived 	obj-firefox/ipc/ipdl/PBrowserStreamChild.cpp:139
7 	xul.dll 	mozilla::plugins::PPluginModuleChild::OnMessageReceived 	obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:426
8 	xul.dll 	mozilla::ipc::AsyncChannel::OnDispatchMessage 	ipc/glue/AsyncChannel.cpp:244
9 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:210
10 	xul.dll 	mozilla::plugins::PPluginModuleChild::CallNPN_UserAgent 	obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:116
11 	xul.dll 	mozilla::plugins::PluginModuleChild::GetUserAgent 	dom/plugins/PluginModuleChild.cpp:396
12 	xul.dll 	mozilla::plugins::child::_useragent 	dom/plugins/PluginModuleChild.cpp:973
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
(In reply to comment #10)
> Hi Aaron,  
> 
> Could I asked you to try a few things.
> 1) Clear your Cache :)
> 2) Do a clean uninstall of the Flash Player
> http://download.macromedia.com/pub/flashplayer/current/uninstall_flash_player.exe
> 
>    1. Click Start > Run.
>    2. Type cmd in the Open box, and then press Enter.
>    3. In the command window, type the following:
> 
>       uninstall_flash_player.exe /clean
> 
> 3)Reinstall the player 
> 4) Reboot 
> 
> Does it still reproduce?

I Uninstalled and Reinstalled and still the same problem...
(In reply to comment #11)
> The latest crash reports are a Mozilla bug and not a flash one. 
> The reporter is running a nightly with OOP
> 
> 0      mozcrt19.dll      memmove       MEMCPY.ASM:188
> 1     xul.dll     nsTArray_base::ShiftData    
> obj-firefox/xpcom/build/nsTArray.cpp:173
> 2     xul.dll    
> nsTArray<mozilla::plugins::BrowserStreamChild::PendingData>::RemoveElementsAt  
>   obj-firefox/dist/include/nsTArray.h:697
> 3     xul.dll    
> nsTArray<mozilla::plugins::BrowserStreamChild::PendingData>::RemoveElementAt   
>  obj-firefox/dist/include/nsTArray.h:702
> 4     xul.dll     mozilla::plugins::BrowserStreamChild::DeliverData    
> dom/plugins/BrowserStreamChild.cpp:239
> 5     xul.dll     mozilla::plugins::BrowserStreamChild::RecvWrite    
> dom/plugins/BrowserStreamChild.cpp:130
> 6     xul.dll     mozilla::plugins::PBrowserStreamChild::OnMessageReceived    
> obj-firefox/ipc/ipdl/PBrowserStreamChild.cpp:139
> 7     xul.dll     mozilla::plugins::PPluginModuleChild::OnMessageReceived    
> obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:426
> 8     xul.dll     mozilla::ipc::AsyncChannel::OnDispatchMessage    
> ipc/glue/AsyncChannel.cpp:244
> 9     xul.dll     mozilla::ipc::RPCChannel::Call    
> ipc/glue/RPCChannel.cpp:210
> 10     xul.dll     mozilla::plugins::PPluginModuleChild::CallNPN_UserAgent    
> obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:116
> 11     xul.dll     mozilla::plugins::PluginModuleChild::GetUserAgent    
> dom/plugins/PluginModuleChild.cpp:396
> 12     xul.dll     mozilla::plugins::child::_useragent    
> dom/plugins/PluginModuleChild.cpp:973

Now that we know its a bug in Mozilla Minefield and not a bug in Flash.  Hopefully the problem can be fixed.
Blocks: OOPP
The crashes with this morning's build 20100225035447 should be fixed by the changes that were backed out this morning.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a29d44f196a6&tochange=059e9961a122

(The crashes in comment 0 are different, though.)
(In reply to comment #14)
> The crashes with this morning's build 20100225035447 should be fixed by the
> changes that were backed out this morning.
> 
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a29d44f196a6&tochange=059e9961a122
> 
> (The crashes in comment 0 are different, though.)

The the little bit of time that I used it on YouTube and Veoh video site yesterday.  It does not appear to be crashing on YouTube and Veoh after the changes were backed out.  But every once in awhile Shockwave Flash crashes in the TalkShoe Chatroom.  When you have the Chatroom maximized and the green volume bar all the way turned up and you are listening to the TalkShoe program then after awhile first the sound will go out then I will see the messege Shockwave crashed right under my Webpage tabs in the TalkShoe Chatroom tab and the Talkshoe user page tab.  It crashes the Talkshoe user page and Talkshoe chatroom.  The chat room is only available on Talkshoe when the user of that particular user page is hosting a live TalkSoe call.

Here is the Crash Report

http://crash-stats.mozilla.com/report/index/bp-0b8b3820-408d-4604-9ea5-b00852100225

http://crash-stats.mozilla.com/report/index/bp-668cfdff-e0a5-4b41-bc26-195fc2100225

And here is the user page that I was at.

http://www.talkshoe.com/talkshoe/web/talkCast.jsp?masterId=28236&cmd=tc
Build platform target i686-pc-mingw32

Build tools
Compiler     Version     Compiler flags
cl     14.00.50727.762     -TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG
-DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl     14.00.50727.762     -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy
-Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952
-O1
Priority: -- → P1
Signature	NPSWF32.dll@0x2e655a
UUID	0b8b3820-408d-4604-9ea5-b00852100225
Process Type	plugin Version: Filename: NPSWF32.dll
Time 	2010-02-25 15:42:46.968910
Uptime	1373
Product	Firefox
Version	3.7a2pre
Build ID	20100225062635
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 15 model 104 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x5ebaff8
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	NPSWF32.dll 	NPSWF32.dll@0x2e655a 	
1 	NPSWF32.dll 	NPSWF32.dll@0x2e21a1 	
2 	NPSWF32.dll 	NPSWF32.dll@0x2e150f 	
3 	NPSWF32.dll 	NPSWF32.dll@0x63dd1 	
4 	NPSWF32.dll 	NPSWF32.dll@0x64012 	
5 	NPSWF32.dll 	NPSWF32.dll@0xadb22 	
6 		@0xf23de7 	
7 	msacm32.drv 	msacm32.drv@0x148d 	
8 	winmm.dll 	waveMessage 	

Filename 	Version 	Debug Identifier 	Debug Filename
NPSWF32.dll 	10.0.45.2 	EF4B0B547B3349C898B243CC64A91FF61 	NPSWF32.pdb
Summary: Shockwave Flash Crashes on YouTube and TalkShoe Flash Chat Rooms → Shockwave Flash Crashes on YouTube and TalkShoe Flash Chat Rooms [@ NPSWF32.dll@0x2e655a]
I would like to point out sense I had this issue I have upgraded Minefield 3.7a4pre and I am still having problems with flash and TalkShoe crashing.  So I desided to listen to TalkShoe through VLC Media player and be in the TalkShoe chat and the chat room was a lot more stable but every now and then the TalkShoe chat would try to freeze.  So there is a problem with both Flash Audio and Flash Video.  Also when you play any flash video on any of the Flash Video sites like YouTube and Maximize the video to full screen.  It don't matter what one.  When you have Windows Live Messenger running and you get a notification that your contact just signed in.  You just got a new email and so on it will automatically shrink the video to half the size of the computer screen and gray out the whole video.  When the notification goes away the video goes back to normal.  I know its not java causing the issue because I didn't have java installed on this fresh install of Windows 7 Pro.  The graying of video also affects some Vista Home Premium Machines as well.
Build platform
target
i686-pc-mingw32

My Theme is Summer Clouds by JoBeLo

http://hg.mozilla.org/mozilla-central/rev/0ca03b113e8a

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests
aaron: until someone asks you for more information, we have everything we need. if someone asks for more information, it should be someone from adobe.
Ok.  Thank you :timeless
Priority: P1 → --
Hi Aaron, 


Would you be willing to try Flash Player 10.1 Beta 3?  I'd like to know how that works for you?  You can download it from http://labs.adobe.com/downloads/flashplayer10.html
I downloaded and installed the flash version 10.1.51.95 Beta 3 debugger version.  It has frozen on some sites that have flash in them already but I want to give it about 1 to 2 weeks and see if it crashes in TalkShoe and websites...
Please don't mess with the tags.
Keywords: shockwave
Priority: P1 → --
Flash is not crashing as bad as it was but there are still some bugs i version 10.1.51.95.  Here is the Adobe debugger tool report.

Type Error:  Error# 1009  Cannot access a propterty or method of null object reference. 

at com.rhapsody.projects.popoutplayer.external.delegates::GetCurrentArtistidDelegate?execute()
at Function/http://adobe/AS3/2006/builtin::apply()
at com.rhapsody.projects.playerengine.external::Delegate/execute()
at Function/http://adobe.com/AS3/2006/builtin::()
at flash.external::Externallnterface$/_calln()
at Function/<anonymous>()

When ever you go to http://www.rhapsody.com/brendan-mulvihill/the-flax-in-bloom
Click on the play button for the first song called "The Reels: The Flax In Bloom / Honeymoon"  It will open up the box asking me if I want to continue like it is supposed to do.  So I click on continue.  Then it will open up the rhapsody player like it is supposed to do and try to load.  While it is trying to load adobe flash crashes and pops up the debugger report I posted above and freezes the browser.
Great Aaron.  I suspected that might be the case.  We've done an amazing amount of work to improve the stability of the player.  The beta version you downloaded does have issues of its own many of we already solved. 

The error you see sounds like a runtime error from using the debug player.  Its something with the code on their end.
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → unspecified
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: Flash 10,1,51,95
Um, why was this marked fixed? There was no patch checked into the mozilla source code.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Whooops, nvm. too much bugmail, to late at night. carry on.....
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
New process fooled ya?  ;)
Yes, you would think all the bugmail I got from timeless the other day would remind me, LOL. But no, my apologies.
This issue is still present in the Beta version.  When you play any flash video on any of the Flash Video sites like YouTube and Maximize the video to full screen.  It don't matter what one.  When you have Windows Live Messenger running and you get a notification that your contact just signed in.  You just got a new email and so on it will automatically shrink the video to half the size of the computer screen and gray out the whole video.  When the notification goes away the video goes back to normal.  I know its not java causing the issue because I didn't have java installed on this fresh install of Windows 7 Pro.  The graying of video also affects some Vista Home Premium Machines as well.  It happens with all browsers.
aaron: sorry, your original report is about a crash. what you're describing now doesn't sound like a crash at all. i'm not even certain it's a bug.

As you're on windows 7, please run 'psr.exe' and record the problem. file a new bug, and attach the psr generated report.
I don't know what psr.exe is
>I don't know what psr.exe is
But google knows it
more importantly, start> knows it!
ok
Crash Signature: [@ NPSWF32.dll@0x2e655a]
Product: External Software Affecting Firefox → External Software Affecting Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.