Bug 546838 (bz-html5)

Upgrade Bugzilla to HTML5

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: GPHemsley, Assigned: Frédéric Buclin)

Tracking

({html5, meta, student-project})

unspecified
Bugzilla 5.0
html5, meta, student-project
Dependency tree / graph
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
(This is a pseudo-meta bug, meaning that it serves double duty.)

I think it's time to bring Bugzilla into the 21st century and switch the templates to HTML5.

And, to clear up any confusion, this proposal does not create any backwards-compatibility problems. HTML5 is more than fancy new tags. It also codifies and clarifies what browsers should have been doing with HTML4. In particular, that means IE6 will not suddenly break as a result of this switch. (At least, not intentionally.) In fact, as Hixie himself has stated, IE6 technically supports more of HTML5 than it does of HTML4, due to the addition of previously-proprietary features to HTML5.

So this bug serves as the home base for the Bugzilla upgrade to HTML5. It may contain its own patches. However, it can also depend on smaller-scope HTML5-related bugs, like bug 546353.

Comment 1

8 years ago
Okay. File specific bugs and explain specifically what you want to do on each of those bugs, and we can take each of those decisions separately.
Keywords: meta

Updated

8 years ago
Alias: bugzilla-html5 → bz-html5
(Reporter)

Comment 2

8 years ago
Created attachment 427539 [details] [diff] [review]
Step Number One

This switches over or adds the HTML5 doctype to all templates with <html> (except the XUL one).

Comment 3

8 years ago
For reference, I don't want to switch the DOCTYPE until there's actually some HTML5 in use.
(Reporter)

Updated

8 years ago
Depends on: 547171
(Reporter)

Updated

8 years ago
Keywords: student-project

Updated

7 years ago
Target Milestone: Bugzilla 4.0 → Bugzilla 5.0
(Assignee)

Updated

6 years ago
Blocks: 686333
Duplicate of this bug: 767707
(Assignee)

Comment 5

5 years ago
We are going to branch for Bugzilla 4.4 next week and this bug is too invasive or too risky to be accepted for 4.4 at this point. The target milestone is set to 5.0 which is our next major release.

I ask the assignee to reassign the bug to the default assignee if you don't plan to work on this bug in the near future, to make it clearer which bugs should be fixed by someone else on time for 5.0.
Target Milestone: Bugzilla 4.4 → Bugzilla 5.0
(Assignee)

Updated

4 years ago
Blocks: 888731
(Assignee)

Comment 6

4 years ago
Created attachment 8356757 [details] [diff] [review]
patch, v2

We are ready to shift to HTML5.
Assignee: ui → LpSolit
Attachment #427539 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8356757 - Flags: review?(justdave)
(Assignee)

Comment 7

4 years ago
Created attachment 8356760 [details] [diff] [review]
patch, v2.1

Oops, I removed [% DEFAULT title = ... %] unintentionally.
Attachment #8356757 - Attachment is obsolete: true
Attachment #8356757 - Flags: review?(justdave)
Attachment #8356760 - Flags: review?(justdave)
(Assignee)

Updated

4 years ago
Keywords: relnote
Comment on attachment 8356760 [details] [diff] [review]
patch, v2.1

Woot.
Attachment #8356760 - Flags: review?(justdave) → review+
I think we missed a few things but they'll be easier to find once the doctype is set correctly so the validators will notice them.
Flags: approval+
(Assignee)

Comment 10

4 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/rest.html.tmpl
modified template/en/default/attachment/diff-header.html.tmpl
modified template/en/default/global/header.html.tmpl
modified template/en/default/list/list-simple.html.tmpl
modified template/en/default/list/server-push.html.tmpl
modified template/en/default/reports/duplicates-simple.html.tmpl
modified template/en/default/reports/report-simple.html.tmpl
modified template/en/default/setup/strings.txt.pl
modified template/en/default/whine/mail.html.tmpl
Committed revision 8856.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Blocks: 673385
(Assignee)

Comment 11

3 years ago
Added to relnotes for 5.0rc1.
Keywords: relnote

Comment 12

2 years ago
(In reply to Dave Miller [:justdave] (justdave@bugzilla.org) from comment #9)
> I think we missed a few things but they'll be easier to find once the
> doctype is set correctly so the validators will notice them.
  
Resolved fixed, and 19 months later this site still uses the legacy DOCTYPE...

Comment 13

2 years ago
(In reply to reelix from comment #12)
> Resolved fixed, and 19 months later this site still uses the legacy
> DOCTYPE...

That is because this site runs Bugzilla version 4.x, while you can see that the Target Milestone of this ticket is set to Bugzilla version 5.0. Hence no contradiction.
You need to log in before you can comment on or make changes to this bug.