Closed Bug 546898 Opened 10 years ago Closed 10 years ago

reftest dynamic-abspos-overflow-01-cols.xhtml fails intermittently due to link coloring mismatch

Categories

(Core Graveyard :: History: Global, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.3a2

People

(Reporter: jfkthame, Assigned: philor)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

We've had two recent tinderbox Rd failures on this test, one on Windows and one on Mac; in both cases, the failure is due to a difference in link coloring between the testcase and reference. The failure looks intermittent, it's not happening on every run.

I suspect this may be a regression from the recent landing of bug 461199 or maybe bug 542592.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266466067.1266469285.1733.gz
WINNT 5.2 mozilla-central debug test reftest on 2010/02/17 20:07:47
s: win32-slave42

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266482207.1266485601.24560.gz
OS X 10.5.2 mozilla-central debug test reftest on 2010/02/18 00:36:47
s: moz2-darwin9-slave14
The async history code doesn't block onload on the link coloring.  We should probably just remove the href attributes from those links, or set them to '#' so they don't appear visited, or something.
Duplicate of this bug: 548420
Blocks: 438871
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267075498.1267080281.5938.gz
Linux mozilla-central debug test reftest on 2010/02/24 21:24:58
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267099041.1267100993.14710.gz
Linux mozilla-central opt test reftest on 2010/02/25 03:57:21
Attached patch Like so?Splinter Review
After a few minutes thinking about whether I had any idea at all which of those choices was better and more future proof (answer: no, no idea), I realized that the problem ought to be susceptible to my skill at randomly mashing on the keyboard. Sadly, the tryserver doesn't suffer from this bug, not being slow enough I guess, but at least it doesn't fail with this.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #428920 - Flags: review?(bzbarsky)
Attachment #428920 - Flags: review?(bzbarsky) → review+
Comment on attachment 428920 [details] [diff] [review]
Like so?

Sounds good.  Let's do it.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267136367.1267138899.31835.gz
OS X 10.5.2 mozilla-central debug test reftest on 2010/02/25 14:19:27
s: bm-xserve16
https://bugzilla.mozilla.org/show_bug.cgi?id=546898
WINNT 5.2 mozilla-central debug test reftest on 2010/02/25 18:42:59
s: win32-slave05
d'oh, copy-paste error on the URL. Comment 10 should have said:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267152179.1267155345.19738.gz
WINNT 5.2 mozilla-central debug test reftest on 2010/02/25 18:42:59
s: win32-slave05
Here, lemme fix it so you don't have to worry about which log you paste :)

http://hg.mozilla.org/mozilla-central/rev/d4c8656eb21a
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a2
Whiteboard: [orange]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.