video.load() doesn't re-examine the <source>s

RESOLVED DUPLICATE of bug 534571

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 534571
8 years ago
8 years ago

People

(Reporter: Simon Pieters, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a2pre) Gecko/20100209 Minefield/3.7a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a2pre) Gecko/20100209 Minefield/3.7a2pre

video.load() doesn't re-examine the <source>s.

Consider:

<video><source></video>
<script>
onload = function(){
  document.body.firstChild.firstChild.src = 'test.ogv';
  document.body.firstChild.load();
}
</script>

Reproducible: Always

Actual Results:  
The resource selection algorithm should be restarted and should load the <source> element.

Expected Results:  
Firefox doesn't seem to load it. (If I create the <source> element with script then it works.)
I can reproduce on Ubuntu Linux/trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534571
You need to log in before you can comment on or make changes to this bug.