New bug in 3.6: Text / form entries ignored after submitting (JSP, PHP, ..)

RESOLVED DUPLICATE of bug 547239

Status

()

--
critical
RESOLVED DUPLICATE of bug 547239
9 years ago
9 years ago

People

(Reporter: michaelof, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

New bug with Firefox 3.6, worked fine with 3.5.7.

After entering data in e.g. text field (single or multiline) within a web application and submitting them by pressing "ok" or whatever is set for submit, Firefox seems to send the datam but instead just empties all fields and "refreshes" the page to the initial, empty level.

Happens with JSP based web applications, also PHP.

Happens e.g. with online banking apps also during login process, looking similar to a phishing attack to an unexperienced user, so serious bug in my point of view

Reproducible: Sometimes

Steps to Reproduce:
1. Select PHP or JSP based website
2. enter data, e.g. user and password
3. press submit/ok/login/whatever
Actual Results:  
3 out 5 tries page is just refreshed, entries deleted/disappeared.

Expected Results:  
"normal" behavour

Firefox 3.6
AddBlock 1.1.1
FireFTP 1.0.7
FlagFox 3.3.20
JavaConsole 5.0.20
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Please try http://support.mozilla.com/en-US/kb/Safe%20Mode

Did as advised. All options enabled, continued with safe mode. 

--> SAME result, bug still exists.

BTW: Also using bugzilla.mozilla.org leads to the bug. Have to click "login" twice very often when using saved passwords. First time ignored.
(Reporter)

Comment 3

9 years ago
Addendum: When clicking "commit" the first time after writing "Comment 2" above, I've got the bugzilla's error message "You apparently didn't choose any bugs to modify.".

Clicked "back" as advised, "commit" again. As you see worked then.

My current workaround is to copy and paste everything I have to enter in forms into notepad temporarily, to be sure. Not that convenient ;-)
do you mean bug 547239 ?
(Reporter)

Comment 5

9 years ago
Guess not. But I can't look inside the JSP code processed by affected sites, so only thing I can confirm that data entries are simply ignored / not passed to the web server within issue described by me. Found several additional sites where problems appears, sometimes they provide some extra information which may help. One web site reports that a "security token" is missing / lost when trying to submit a page. Also several times login data is lost with Firefox 3.6. As your email seems to be German, I could provide you the URLs if you want, they're all German. Except bugzilla.mozilla.org :-)
(Reporter)

Comment 6

9 years ago
Actually seems to be bug 547239. Problem is fixed in 3.6.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547239
You need to log in before you can comment on or make changes to this bug.