When copying topic names on boards two spaces are added




8 years ago
7 years ago


(Reporter: Kamil, Unassigned)


Windows XP

Firefox Tracking Flags

(Not tracked)





8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv: Gecko/20091201 Firefox/3.5.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv: Gecko/20091201 Firefox/3.5.6

Simply visit url, copy any topic name and paste it anywhere, at the end of copied-pasted content there will be 2 spaces. It happens on board engine like on Mozillazine also on IP.Board. Also there is on more thing which I doubt will be changed, details: http://forums.mozillazine.org/viewtopic.php?f=38&t=1746915

Reproducible: Always

Steps to Reproduce:
Please read details section.
Actual Results:  
Please read details section.

Thank you for fixing my problem about conflict with Visual Clipboard application.

Comment 1

8 years ago
WFM - If I go to the URL and copy the topic ("Find on page" function in 3.6 - changed behavior) I am not seeing any issues. 

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

Does the issue still occur if you are not using Visual Clipboard?

Comment 2

8 years ago
Thank you for respond. Please go to http://forums.mozillazine.org/viewforum.php?f=38 highlight any topic, let's choose first one "INSTANT HELP — Frequently Asked Questions", next choose copy and then paste - anywhere findbar, locationbar, other application. There will be two spaces at the end. I've described quite clear in topic: "Find on page" function in 3.6 - changed behavior 
I've posted there short clip, hope it will help.

Safe Mode doesn't help, also VC is not a problem. It's something with Fx for sure, in Opera it works fine.

Comment 3

8 years ago
With the new link I do see the extra 2 spaces with copy/paste (when pasted within or outside Firefox).

Reviewing website code does not reveal any spaces. Sample code:

<dt title="This topic is locked, you cannot edit posts or make further replies."><a href="./viewtopic.php?f=38&amp;t=106431&amp;sid=87301243c024c32e941271fa624636a7" class="topictitle">INSTANT HELP — Frequently Asked Questions</a><br>by <a href="./memberlist.php?mode=viewprofile&amp;u=52838&amp;sid=87301243c024c32e941271fa624636a7" style="color: rgb(0, 170, 0);" class="username-coloured">Filipp0s</a> » July 27th, 2004, 4:59 pm</dt>

However, taking just that code and doing a local html file does not exhibit the issue.


8 years ago
Component: General → Shell Integration
QA Contact: general → shell.integration


7 years ago
Version: unspecified → 3.6 Branch
Not a shell integration bug... very likely a core bug but I'm unsure which component. Over to Core -> General for further triage
Component: Shell Integration → General
Product: Firefox → Core
QA Contact: shell.integration → general
Version: 3.6 Branch → 1.9.1 Branch

Comment 5

7 years ago
Still seeing at least one space after the text on Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110613 Firefox/7.0a1 ID:20110613030722

Updating version to trunk and confirming
Ever confirmed: true
Version: 1.9.1 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.