drag'n drop images or links inside document loads them

RESOLVED WONTFIX

Status

Mozilla Labs
Jetpack Prototype
--
major
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Yannick Lavoquer, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6

Tested with a fresh profile and Jetpack 0.8.1

This breaks the ability for users to move an image on the document containing it (e.g. a compass in order to read angles)

Reproducible: Always

Steps to Reproduce:
1. Open URL [ https://jetpack.mozillalabs.com/ ]
2. Scroll down to "featured Jetpack" section
3. Drag the jetpack icon displayed there and drop it inside this page
Actual Results:  
this icon [ https://jetpack.mozillalabs.com/images/thumb.png ] is loaded


Expected Results:  
Nothing should happened, until I drop the icon into tabbar or navbar.
This is the common behavior of Firefox from version 3.5 to Trunk

I can't reproduce this when drag'n drop a backgrounded image. Such as large Firefox icon (sprite2.png) displayed at http://www.google.fr/firefox?client=firefox-a&rls=org.mozilla:fr:official

Verified also with last Firefox 3.5.* and Minefield [3.7a2pre]
Works fine on Windows XP
We will be monitoring all these issues after the rebooted Jetpack code base is released in the first week of March to ensure their causes are not duplicated. Many of the bugs/issues with the prototype version of Jetpack will be made irrelevant given the structure of the new SDK.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.