Saying Java is required

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: colin.internet, Unassigned)

Tracking

({regression})

Trunk
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6

Have firefox 3.6, and latest Java (Version 6 Update 18).
The page in question says java is required, enable java, but there is no java option under tools>options>content.

I have confirmed that the plugin is installed here and it is 
http://www.java.com/en/download/help/testvm.xml



Reproducible: Always

Steps to Reproduce:
1.Visit http://www.mini.co.uk/html/ecom/ecom.html?s3_route=quicklink
2.
3.
Actual Results:  
Says Java is required.

Expected Results:  
Be able to configure the car you want to buy.

I tested this on another machine running XP.

On firefox 3.5.8 it worked fine. I then upgraded java to Version 6 Update 18 and it still worked.
I then upgraded firefox to 3.6 and the page no longer worked.

I've also checked the page in IE 8 and IE8 64 bit and they both work.
Yeah, seeing it with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100217 Minefield/3.7a2pre ID:20100217050024. Not sure if this is a TE bug though
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
The information on the web site is out of date. Java is no longer enabled via tools>content>options but by tools>Add Ons->(Select Java)>Click the Enable/Disable button.
(Reporter)

Comment 3

9 years ago
I've looked in Tools add>ons and they are all there enabled.

Java platform SE v6 u18
Java development toolkit 6.0.180.7

Under extensions java console is there 6.0.18

When you go to tools>java console, nothing opens up whereas it did in previous versions of Firefox.

This error only happened after upgrading to firefox 3.6. On 3.5.7 and 3.5.8, the page loaded up fine.
As Tyler said, there may be other issues.
(Reporter)

Comment 5

9 years ago
What is TE bug?
So any ideas what these other issues could be?
Tech Evangelism - where someone asks the site to change

Not really. There's lots of code and at first glance the key stuff may be in an applet. If so I'm not sure there's much we can do other than to notify the site.
I see no errors in the error console. I guess a regression window would tell more about the cause.
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 8

9 years ago
I'm not technically knowledgeable when it comes to java applets but if the applet works fine in IE 8 32 bit and 64 bit with the latest java release, but not Firefox 3.6, even though it worked in 3.5.8, I can only assume it is the way Firefox is loading the applet or dealing with the java plugin.
The java console not opening indicates a problem with our interaction with the java plug-in, not with the site.

Tyler, do you also see the java console not opening?

Colin, Tyler, does java work on any sites at all?
Boris,
I don't have the java console. But, when i go to http://java.com/en/download/help/testvm.xml, java works just fine.
Ria, Colin, Tyler, could one of you perhaps hunt down a regression range for this bug?
(Reporter)

Comment 12

9 years ago
(In reply to comment #10)
> Boris,
> I don't have the java console. But, when i go to
> http://java.com/en/download/help/testvm.xml, java works just fine.

Java plugin worked fine on FF version 3.5.8 from this link too, and the console opened as well. I checked on my windows xp laptop before I upgraded to 3.6.
Could this be caused by the disabling of the OJI plugin ?
My Java installation (JRE1.6 U18) works fine with SM trunk but fails on this page.
I get this in the java console :

>size 1102x732
>Java Version: 1.6.0_18
>Max. Memory: 123.75 MB
>Total Memory: 15.63 MB
>
>
>VCO Highline 6.2 Build: 23, 17-12-2009
>Configurator alive and initialized for (brand,lang,[variant]country): MINI, en, GB
>Sulzer Standard Ruleinterpreter(c) 2.2, Sulzer GmbH, Munich
>KB Server: /ecom40/vco_oookb_servlet/OOOKBConnectionServlet
>KB Key: MI_en_GB
>
>Logger settings:
>-level: ERROR ***
>-timer: false
>-select:[]
>-reject:[]
>
>User-Agent:Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.3a2pre) >Gecko/20100214 SeaMonkey/2.1a1pre
> Could this be caused by the disabling of the OJI plugin?

Really, hunting down a regression range would answer this sort of question better than speculating.  ;)
(Reporter)

Comment 15

9 years ago
(In reply to comment #14)
> > Could this be caused by the disabling of the OJI plugin?
> 
> Really, hunting down a regression range would answer this sort of question
> better than speculating.  ;)

I'm afraid you have lost me there. I'd like to help but no idea what this is. Any guidance you can give I'd appreciate.
Colin, we have arhives of builds day by day for every single day going back several years.  I'm asking whether someone who can reproduce this bug would be willing to go through the builds (doing a binary search on them, basically) and find the exact day when the problem appeared.  At that point we'll have a list of a few dozen changes that might have caused it, instead of the thousands of changes from 3.5 to 3.6.

The builds are at ftp://ftp.mozilla.org/pub/firefox/nightly/ in by-date directories.  3.5 corresponds to about August 2008 for the mozilla-central builds.  3.6 corresponds to about December 2009.  That's about 450 days, so needs about 9-10 builds tested.

Comment 17

9 years ago
Build worked : Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) 
Gecko/20090314 Minefield/3.2a1pre
Build broken : Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) 
Gecko/20090315 Minefield/3.2a1pre

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=aa75d2c8a862&tochange=8a3c6f9a258f

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 ID:20100824153629 & Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre with Next Generation Java Plug-in    Version: 6.0.230.1/1.6.0_23 for Mozilla browsers.

During the Loading of the Java Configurator the "no Java Found" Error Page is briefly visible, but then it moves on.

Also i checked the Regrange of Comment 17: with Build 20090315 i get the same Result as with recent Builds.
Keywords: regressionwindow-wanted
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested this on Win 10 x64 with the latest Firefox release (46.0.1) and the latest Nightly(49.0a1-20160530030222) and it is not reproducible. Tried also to reproduce also on the reported versions but still with no luck. 
Indeed the provided link does not redirects now straight to the car configurator, but if you chose it afterwards, you can configure your car without any issue.

Considering that the java version was updated and the website might had also been updated since then, I will mark this issue as Resolved-WORKSFORME. If anyone still encounters this issue feel free to reopen it providing more details or file a new one.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.