OSX: Application Keyboard Shortcuts to change cmd+c to ctrl+c do not work

RESOLVED DUPLICATE of bug 429824

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 429824
8 years ago
8 years ago

People

(Reporter: cirwin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: Firefox/3.5.8

Even though I am on a Mac, most of my work is done in a Windows VM. I changed the cut, copy, and paste keyboard shortcuts from the cmd key to the ctrl. It works for Safari and many other mac applications, but not with Firefox. 

Reproducible: Always

Steps to Reproduce:
1.On my mac, I go into System Preferences > Keyboard & Mouse > Keyboard Shortcuts > Application Keyboard Shortcuts > All Applications.
2. Add keyboard shortcuts for Paste (^v), Cut (^X), and Copy (^c).
3. In Fireforx, try to copy or paste within the application or to/from the application.
Actual Results:  
No success in copying or pasting using the ctrl+ key. The cmd+ key still controls the keyboard shortcut.

Expected Results:  
Using ctrl+c should copy the selected text into memory to be pasted elsewhere.

Comment 1

8 years ago
customising keyboard shortcuts through the System Preferences pane is busted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.