not migrating "browser.bookmark_file" pref

VERIFIED WONTFIX

Status

Core Graveyard
Profile: Migration
P3
normal
VERIFIED WONTFIX
17 years ago
a year ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: dbragg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

in 4.x, on unix, it looks like we have a pref "browser.bookmark_file" that
points to the bookmarks file.

in most cases, it is ~/.netscape/bookmarks.html, which is what we assume it to
be in the 6.0 profile migration code.

But, it is possible for that pref to be set to another file.

see http://lxr.mcom.com/nova/search?string=bookmark_file

we need to change nsPrefMigration.cpp to use the "browser.bookmark_file pref (on
unix) if it is set.
Seth: is this a dupe of bug 31623?

Gerv
We decided not to do this, as sharing bookmarks between 4.x and Mozilla isn't a
good idea. People can set the new pref, browser.bookmarks.file, if they want to
set an alternate bookmarks file in Mozilla.

Gerv
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 3

17 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.