Incorrect winners are chosen after a design challenge completes

VERIFIED FIXED in 1.1

Status

--
critical
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: krupa.mozbugs, Assigned: ryansnyder)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

9 years ago
steps to reproduce:
1.Go to http://mcc.stage.mozilla.com/challenges/52
2.Notice the winners for this design challenge.Both have zero votes

expected results:
Winners should have been-
Purple guy-2 votes
Woof-1 vote
red dog-1 vote

actual results:
Clouds and extra solar giants (both have zero votes) are chosen as winners.
Great catch (really glad you caught that).  Here's a fix for it.  

Since we now have 2 different challenges, we will need to verify that design winners are awarded properly both before and after Feb 1.

==

Sending        application/controllers/challenges.php
Sending        application/models/design_vote.php
Transmitting file data ..
Committed revision r62662.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
And adding the view files...

==

Deleting       application/views/challenges/challenges_view_not_current_past.php
Adding         application/views/challenges/challenges_view_not_current_past_v1.php
Adding         application/views/challenges/challenges_view_not_current_past_v2.php
Transmitting file data ..
Committed revision r62663.
(Reporter)

Comment 3

9 years ago
the challenge looks fine now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.